Opened 7 years ago

Closed 6 years ago

#6058 closed defect (not a bug)

TBB on OS X 10.5.8 with "Firefox-bin quit unexpectedly"-error

Reported by: runa Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: g.koppen@…, ornyfoecker@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Two users with OS X 10.5.8 have reported that version 2.2.35-12 of the Tor Browser Bundle fails to start. While Vidalia shows that Tor is establishing a circuit, a box appears with "The application Firefox-bin quit unexpectedly" and the screen freezes.

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 7 years ago by runa

One user tested and was not able to reproduce this issue.

comment:3 Changed 7 years ago by AllOut

Cc: ornyfoecker@… added

I also have this problem. Tor was running beautifully for me yesterday. I finally decided to upgrade, so I downloaded & installed TorBundle TorBrowser-2.2.38-2-osx-x86_64-en-US. Now when I start TorBrowser_en-US.app, Vidalia starts up like normal. The Tor icon goes green. Then I get "firefox-bin quit unexpectely." Tor is still up; I just can't get to a browser.

OSX 10.5.8
FF14.0.1 is installed (if that is relevant at all)

Logs say:
Sep 01 10:49:38.427 [Notice] Tor v0.2.2.38 (git-49d150a9fad2cb8d). This is experimental software. Do not rely on it for strong anonymity. (Running on Darwin i386)
Sep 01 10:49:38.428 [Notice] Initialized libevent version 2.0.19-stable using method kqueue. Good.
Sep 01 10:49:38.428 [Notice] Opening Socks listener on 127.0.0.1:0
Sep 01 10:49:38.429 [Notice] Socks listener listening on port 57956.
Sep 01 10:49:38.429 [Notice] Opening Control listener on 127.0.0.1:0
Sep 01 10:49:38.429 [Notice] Control listener listening on port 57957.
Sep 01 10:49:38.430 [Notice] Parsing GEOIP file ../../Contents/Resources/Data/Tor/geoip.
Sep 01 10:49:39.943 [Notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 01 10:49:39.943 [Notice] We now have enough directory information to build circuits.
Sep 01 10:49:39.944 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 01 10:49:39.944 [Notice] New control connection opened.
Sep 01 10:49:40.466 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 01 10:49:40.760 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Sep 01 10:49:49.433 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Sep 01 10:49:49.433 [Notice] Bootstrapped 100%: Done.

On the Mac Console I get:
9/1/12 11:04:19 AM [0x0-0x19c19c].org.mozilla.firefox[2031] restoring member tabs = 19
9/1/12 11:07:30 AM ReportCrash[2058] Formulating crash report for process firefox-bin[2057]
9/1/12 11:07:30 AM ReportCrash[2058] Saved crashreport to /Users/John/Library/Logs/CrashReporter/firefox-bin_2012-09-01-110730_xxxxxxs-computer.crash using uid: 501 gid: 501, euid: 501 egid: 501

See the line with all the * in front of it. So for some reason it's trying to restore my normal Firefox profile with my existing tabs. Shouldn't it be opening up a different instance of Firfox ("Aurora") with a different profile?

comment:4 Changed 7 years ago by rransom

Status: newneeds_information

Is MacOS 10.5 still receiving security updates from Apple?

comment:5 Changed 6 years ago by johntrapp

Status: needs_informationnew

I get the same error message.
Running:
Vidalia 0.2.21
Tor 0.2.3.25
Max OS X V 10.5.8

comment:6 Changed 6 years ago by GentlemanGent

New to Tor...first time ever attempting to download and run TBB.

First attempt: I downloaded the non-64bit version onto an external hardrive and opened Tor from there. The firefox-bin problem popped up. Tor and Vidalia worked fine, just couldn't use any browser. I uninstalled the TBB.

Second attempt (hours later): Realized I could use the 64bit version. Downloaded the 64bit version of TBB into my computer hardrive>Applications folder. I encountered the "Firefox-bin quit unexpectedly"- error again. Tor is able to create a circuit and stay connected. Vidalia is fully functional as well. There is a button to attempt to relaunch Firefox, and that was unsuccessful.

Mac Pro Dual-Core Intel Xeon (64bit)
Running:
OSX 10.5.8
Firefox 16.0.2

Message log below (from 64 bit version):
Mar 13 15:48:55.291 [Notice] Tor v0.2.3.25 (git-17c24b3118224d65) running on Darwin.
Mar 13 15:48:55.292 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Mar 13 15:48:55.292 [Notice] Read configuration file "/Applications/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../../../../../Library/Vidalia/torrc".
Mar 13 15:48:55.296 [Notice] Initialized libevent version 2.0.21-stable using method kqueue. Good.
Mar 13 15:48:55.296 [Notice] Opening Socks listener on 127.0.0.1:9150
Mar 13 15:48:55.297 [Notice] Opening Control listener on 127.0.0.1:9151
Mar 13 15:48:55.297 [Notice] Parsing GEOIP file ../../Contents/Resources/Data/Tor/geoip.
Mar 13 15:48:55.966 [Notice] This version of OpenSSL has a known-good EVP counter-mode implementation. Using it.
Mar 13 15:48:55.967 [Notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Mar 13 15:48:55.967 [Notice] Reloaded microdescriptor cache. Found 3297 descriptors.
Mar 13 15:48:55.967 [Notice] We now have enough directory information to build circuits.
Mar 13 15:48:55.967 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Mar 13 15:48:55.968 [Notice] New control connection opened.
Mar 13 15:48:56.752 [Notice] Heartbeat: Tor's uptime is 0:00 hours, with 5 circuits open. I've sent 0 kB and received 0 kB.
Mar 13 15:48:56.863 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Mar 13 15:48:57.171 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Mar 13 15:48:58.056 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Mar 13 15:48:58.056 [Notice] Bootstrapped 100%: Done.

To answer rransom's question, I don't believe MacOS 10.5 receives security updates anymore. I can't remember the last time I got one.

comment:7 Changed 6 years ago by erinn

Resolution: not a bug
Status: newclosed

Hi,

I'm sorry but this isn't a bug. It says on the Tor Browser page that we only support 10.6 and up, and this is mostly because Firefox changed their support plans to only support 10.6 and up.

https://www.torproject.org/projects/torbrowser.html.en

I think we used to say that on the download page itself, but it seems that is not the case? So while not a bug, we should be more clear about what versions we support on the page where most people are actually downloading TBB...

Note: See TracTickets for help on using tickets.