Opened 7 years ago

Closed 5 years ago

#6062 closed defect (fixed)

Tor Browser wont start via pinned link or shortcut? in windows start menu

Reported by: trallala Owned by: mcs
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor Browser Version:
Severity: Keywords: needs-triage, TorBrowserTeam201408
Cc: Shondoit, BugMagnet, mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

title says it all

also, window controls (minimize, maximize, close) are invisible on vista

on a completely unrelated note: your last torbutton update was messed up as tor mode continued to be active even after uninstalling torbutton (i switched it of in the firefox menu but im pretty sure there are some people out there who wouldnt know to do that)

and yes i know, you hate it when multiple issues are cramped into one ticket but i dont really think the other 2 deserve a ticket of their own, especially the torbutton one, since you wont be developing that anymore, just thought id bring it to your attention.

Child Tickets

Change History (12)

comment:1 Changed 7 years ago by andrea

Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:2 in reply to:  description Changed 7 years ago by rransom

Cc: Shondoit added

Replying to trallala:

title says it all

Your shortcut probably has the wrong ‘Working Directory’ set. ‘Start Tor Browser.exe’ needs to be run from the ‘Tor Browser’ directory. Maybe it should learn to find the directory it lives in and chdir appropriately (like the Linux startup script).

also, window controls (minimize, maximize, close) are invisible on vista

Duplicate of a now-fixed ticket that I'm not going to go looking for.

on a completely unrelated note: your last torbutton update was messed up as tor mode continued to be active even after uninstalling torbutton (i switched it of in the firefox menu but im pretty sure there are some people out there who wouldnt know to do that)

Also a duplicate of a very serious bug, which mikeperry claimed to be unable to reproduce even though multiple users reported it.

and yes i know, you hate it when multiple issues are cramped into one ticket

Yes, we do hate tickets with multiple issues in them.

comment:3 Changed 6 years ago by BugMagnet

I am a Tor newbie, only *trying* to run it for a few days now. Am finding it VERY frustrating. I appreciate it is like much good software FLOSS and I like that and am understanding such is a pro bono community effort. I am told Vidalia is being deprecated and abandoned (yet i see some comments within the last few weeks indicating some fixing might continue, so I remain confused on actual plans moving ahead).

For now, I am simply experimenting with TBB and have this to report FWIW:

Testing tor-browser-2.3.25-13_en-US.exe on a Win XP Media Center 2002 platform -

  • Run "Start Tor Browser.exe" itself from the directory it was extracted to (C:\Tor Browswer\*) - result, vidalia, tor and browser open and success! - tor check website reports: "Congratulations. Your browser is configured to use Tor."
  • Create shortcut for "Start Tor Browser.exe" and "Pin to Start Menu". Note, by default, shortcut option for "Start in:" was set to "C:\Tor Browser". Click on "Start Menu" shortcut - result, vidalia, tor and browser open and success! - tor check website reports: "Congratulations. Your browser is configured to use Tor."
  • Select "C:\Tor Browser\Start Tor Browser.exe" and "Pin to Start Menu". Note, on "Properties for this pinned link, "Location" shows "C:\Tor Browser". Click to run pinned link from start menu - result - FAIL - vidalia runs but can't find tor so it and browser never starts.

Seems a pinned link, even though showing the executable is located in "C:\Tor Browser\" directory, doesn't set it while the shortcut's option to "Start in" "C:\Tor Browser" handling seems to work. Fields for the pinned link are not editable from "Properties" as they are for shortcuts.

While there may or may not be a windows bug in properly handling pinned links, I am guessing that using relational paths instead of full paths in vidalia is related to this problem. If so, having vidalia learn the location of the 'install/extract' directory and appending that to the paths so they would be full instead of relational would fix this I think.

Also, a little off topic but perhaps related, I am finding TBB is creating files and folders outside the install/extract/run directory tree (C:\Tor Browser\*). This is very different from the incidental tracks and traces left behind as reported in https://research.torproject.org/techreports/tbb-forensic-analysis-2013-06-28.pdf. The current FAQ at https://www.torproject.org/docs/faq.html.en#HowUninstallTor claims:

Tor Browser does not install itself in the classic sense of applications. You just simply delete the folder or directory named "Tor Browser" and it is removed from your system.

This is not true since TBB under some circumstances is creating files and folders outside the "Tor Browser" directory such as:

  • C:\Documents and Settings\user1\Application Data\tor contains several operational files
  • C:\Documents and Settings\user1\Data\Vidalia contains vidalia.conf
  • C:\Program Files\tor\ contains a tor log file

I think these are created when TBB is confused when running without the "Start in" directory properly set and the relational paths therefore becoming ambiguous. I have documented changes to torrc and vidalia.conf made by vidalia under such circumstances, but have been told vidalia is old and won't be fixed. My concern is making these issues known, so that whatever is coming to replace vidalia won't mimic its problematic behaviors on these issues.

Last edited 6 years ago by BugMagnet (previous) (diff)

comment:4 Changed 6 years ago by BugMagnet

Further testing and documentation:

Works as expected: Running "Start Tor Browser.exe" itself from the directory it was extracted to (C:\Tor Browswer\*):

CMD = App/vidalia.exe --datadir .\Data\Vidalia\
Curr Dir = C:\Tor Browser\
Path = C:\Tor Browser\App\vidalia.exe

Works as expected: Running shortcut created for "Start Tor Browser.exe" that was "Pin to Start Menu".

CMD = App/vidalia.exe --datadir .\Data\Vidalia\
Curr Dir = C:\Tor Browser\
Path = C:\Tor Browser\App\vidalia.exe

FAILED: Select executable file "C:\Tor Browser\Start Tor Browser.exe" and "Pin to Start Menu". Click that Start Menu link to run. - Fails to find tor, hence neither tor nor browser open.

CMD = App/vidalia.exe --datadir .\Data\Vidalia\
Curr Dir = C:\Documents and Settings\user1\ <=======<<<<<
Path = C:\Tor Browser\App\vidalia.exe

Note: When starting TBB from a pinned link, it fails to set the "Start In" location to the folder where (Start Tor Browser.exe) has been extracted. It defaults to the user's folder in C:\Documents and Settings\current user\ instead of C:\Tor Browser\

Because of this, an error dialog appears:

"Error Starting Tor"

Vidalia was unable to start Tor. Check your settings to ensure the correct name and location of your Tor executable is specified.[Show Settings] [Cancel] [Help]

Clicking [Show Settings] button revealed that Vidalia had by default set the Tor path = C:\Program Files\Tor\tor.exe due to running in the wrong current directory.

When vidalia starts, might it not be possible for it to determine where vidalia.exe itself is located (here, C:\Tor Browser\App\vidalia.exe) then simply do > "CD C:\Tor Browser\" where "Start Tor Browser.exe" is located upon which all relational paths are based?

I just noticed Shondoit made this suggestion above:

Your shortcut probably has the wrong ‘Working Directory’ set. ‘Start Tor Browser.exe’ needs to be run from the ‘Tor Browser’ directory. Maybe it should learn to find the directory it lives in and chdir appropriately (like the Linux startup script).

On win XP, one can edit "Start In" directory in a shortcut but that is not an option for a link pinned to the Start Menu. Quirky windows behavior it seems to me, since the properties for the pinned link show the directory where "Start Tor Browser.exe" is located. I simply does not set it as the current working directory for some reason. As Shondoit suggested, having vidalia check this and doing a CD or chdir before trying to run other executables (i.e. Tor or tbb-firefox) based on relational paths is what needs to be done.

I think this will also fix the problem where, when confused about the current running directory, TBB writes file and folders outside its own directory.

Last edited 6 years ago by BugMagnet (previous) (diff)

comment:5 in reply to:  description Changed 6 years ago by BugMagnet

Replying to trallala:

title says it all

My tests on XP indicate a different result. TBB works from a shortcut but instead fails to function when TBB is started from a link to "Start Tor Browser.exe" that is pinned to the Start Menu.

comment:6 Changed 6 years ago by BugMagnet

Cc: BugMagnet added
Summary: Tor Browser wont start via shortcut in windows start menuTor Browser wont start via pinned link or shortcut? in windows start menu

comment:7 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:8 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:9 Changed 5 years ago by mcs

Keywords: TorBrowserTeam201408 added

This may be fixed in the 4.0 alpha series due to the #11641 reorg. and other recent changes. I will try to remember to check soon.

comment:10 Changed 5 years ago by brade

Cc: mcs brade added

comment:11 Changed 5 years ago by mikeperry

Owner: changed from tbb-team to mcs
Status: newassigned

comment:12 Changed 5 years ago by mcs

Resolution: fixed
Status: assignedclosed

My testing shows that Tor Browser 4.0a1 can be started from the Start Menu and Task Bar after pinning.

I created a new ticket #12885 for some follow up work related to the Win7/8 jump list feature.

Note: See TracTickets for help on using tickets.