Opened 7 years ago

Closed 3 years ago

#6083 closed defect (wontfix)

Restore toggle for torbutton

Reported by: mikeperry Owned by: cypherpunks
Priority: High Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords:
Cc: arma, phobos Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Apparently we probably should not have disabled toggle in one release. We should have put out an interim release with the warning before disabling it. I can probably restore toggle in an update without breaking things in a day or two... I guess I should give that a shot.

It's just so depressing that we need years to get a message out to our userbase and don't really have the resources to properly keep them safe.

Child Tickets

Change History (10)

comment:1 Changed 7 years ago by mikeperry

Cc: arma added
Keywords: MikePerry201206 removed
Owner: set to cypherpunks
Priority: blockermajor
Status: newassigned

Ok, I agonized over this all of last night, barely sleeping. Here's my final opinion:

I will not ship known-broken configurations. I am here to build the future, not support the dying past. I will devote no effort to it, other than to help it die more quickly.

If people really want Torbutton-toggle to exist, then the community will have fix the bugs, including issues with proxy bypass through plugins, webthreads, websockets, popup race conditions, other addon activity, spdy, and on and on and on.

People who want to have an insecure browsing experience wrt proxy bypass and web tracking are otherwise free to install Foxyproxy. Or simply re-enable toggle using the checkbox at the bottom of the proxy preferences.

comment:2 Changed 7 years ago by mikeperry

Summary: Restore toggle for torbutton for another release or twoRestore toggle for torbutton

comment:3 Changed 7 years ago by phobos

Maybe not the correct ticket, but when a user installs this new non-toggle torbutton, how can they get their pre-torbutton data and settings returned? apparently un-installing the torbutton add-on doesn't do it in firefox 13 or something.

comment:4 Changed 7 years ago by phobos

Cc: phobos added

comment:5 in reply to:  1 Changed 7 years ago by arma

Replying to mikeperry:

Or simply re-enable toggle using the checkbox at the bottom of the proxy preferences.

How about renaming the checkbox so it's clear that's what it does?

comment:6 Changed 7 years ago by mikeperry

arma: Renaming the checkbox will delete the current translations, but if a patch appears, I could be persuaded to merge it.

phobos: As for uninstalling the button breaking settings, that sounds like either a separate Firefox 13 regression or some other issue specific to that user. I explicitly tested uninstall in Firefox 12 before deploying #3838, and it properly reset my saved non-tor settings upon uninstall.

Further, if it is true, it probably also means that toggle is actually really broken on Firefox 13 now, because settings reset uses the same exact codepath as toggle.

comment:7 Changed 7 years ago by mikeperry

phobos: fwiw, on MacOS FF13, uninstalling still works fine, and yields a Firefox with no tor proxy settings set.

comment:8 in reply to:  6 ; Changed 7 years ago by arma

Replying to mikeperry:

arma: Renaming the checkbox will delete the current translations, but if a patch appears, I could be persuaded to merge it.

Losing the translations of a wrong string, along with the wrong string, sounds fine to me.

comment:9 in reply to:  8 Changed 7 years ago by mikeperry

Replying to arma:

Replying to mikeperry:

arma: Renaming the checkbox will delete the current translations, but if a patch appears, I could be persuaded to merge it.

Losing the translations of a wrong string, along with the wrong string, sounds fine to me.

I still think it's very wrong of us to let one troll (note: the same guy who told us to "burn in hell" on #tor-dev said he left a message on Andrew's voicemail) cause us to make it easier for people to get owned.

I admit that we should have done two releases: One with the warning, and one with actually disabling it. Since we can't go back in time to do this, we should just forget about it, and move on.

Specific trolls can be told how they can put themselves in danger on a case by case basis. Just give them this url: https://trac.torproject.org/projects/tor/ticket/3838#comment:18

comment:10 Changed 3 years ago by bugzilla

Resolution: wontfix
Severity: Normal
Status: assignedclosed
Note: See TracTickets for help on using tickets.