Opened 7 years ago

Closed 3 years ago

#6101 closed enhancement (duplicate)

Support SPDY in TBB Alpha

Reported by: mikeperry Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This primarily involves disabling the SPDY state storage and ensuring its connections are properly closed on New Identity.

Child Tickets

Change History (9)

comment:1 Changed 7 years ago by mikeperry

We may also want to limit keepalive duration to 20 seconds, unless the spdy keepalive duration is also governed by the HTTP keepalive parameter in Firefox.

comment:2 Changed 7 years ago by mikeperry

See #4603 for codepaths that are probably close to the spdy keepalive codepaths.

comment:3 Changed 7 years ago by mikeperry

Type: defectenhancement

comment:4 Changed 7 years ago by mikeperry

SPDY just underwent a couple protocol revisions. Firefox 15 now supports "SPDY v3"

We should verify nothing evil was added and see if it gives us more opportunity for non-determinism for website traffic fingerprinting. In particular, there's now flow control stuff to play with in v3.

comment:5 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:6 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Owner: changed from mikeperry to tbb-team

comment:7 Changed 3 years ago by bugzilla

Keywords: tbb-linkability tbb-firefox-patch removed
Resolution: invalid
Severity: Normal
Status: newclosed

Obsolete.

comment:8 Changed 3 years ago by gk

Resolution: invalid
Status: closedreopened

comment:9 Changed 3 years ago by gk

Cc: gk added; g.koppen@… removed
Resolution: duplicate
Status: reopenedclosed

Duplicate of #14952.

Note: See TracTickets for help on using tickets.