Opened 8 years ago

Closed 6 years ago

#6129 closed enhancement (not a bug)

Inform users about permission issues through FAQ

Reported by: Shondoit Owned by:
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When a users extract TBB to a privileged location like %ProgramFiles% then Firefox will start up with the confusing message "Firefox is already running. (...)"
The problem is not that Firefox is running, but that it cannot write a lock file. (see #4782)

We should inform users about this issue and that they should extract the bundle to a non-privileged location. This will be added in the short user manual (#5757). But having this available in the FAQ allows us to point users to it, instead of mailing or linking tsum.

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by runa

Why can't we put that on the download page instead, right next to the download button? Users are more likely to see it there when they download Tor.

comment:2 in reply to:  description Changed 8 years ago by arma

Replying to Shondoit:

When a users extract TBB to a privileged location like %ProgramFiles% then Firefox will start up with the confusing message "Firefox is already running. (...)"
The problem is not that Firefox is running, but that it cannot write a lock file. (see #4782)

If this is actually the behavior, one of the steps we should take is filing the bug with upstream. That's a mighty misleading error message for "I can't write to disk".

comment:3 Changed 8 years ago by phobos

Owner: phobos deleted
Status: newassigned

comment:4 Changed 8 years ago by phobos

someone should write up the faq and runa or I can commit it.

comment:5 Changed 6 years ago by Sebastian

Resolution: not a bug
Status: assignedclosed

This doesn't happen anymore

Note: See TracTickets for help on using tickets.