Opened 7 years ago

Closed 12 months ago

#6134 closed defect (wontfix)

Vidalia crash on Windows 7 Ultimate 64-bit

Reported by: keystroke Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.2.17
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Vidalia has crashed twice over the last week when closing the application.

Crash 1:
Description
Faulting application name: vidalia.exe, version: 0.2.17.0, time stamp: 0x4fad624c
Faulting module name: QtCore4.dll, version: 4.8.1.0, time stamp: 0x4f6c7688
Exception code: 0xc0000005
Fault offset: 0x00249020
Faulting process id: 0x11f4
Faulting application start time: 0x01cd46b0bcd3fcaa
Faulting application path: C:\Program Files (x86)\Tor Browser\App\vidalia.exe
Faulting module path: C:\Program Files (x86)\Tor Browser\App\QtCore4.dll
Report Id: caf834c1-b2a4-11e1-9781-60eb69d93c5d

Crash 2:
Description
Faulting application name: vidalia.exe, version: 0.2.17.0, time stamp: 0x4fad624c
Faulting module name: QtCore4.dll, version: 4.8.1.0, time stamp: 0x4f6c7688
Exception code: 0xc0000005
Fault offset: 0x00249020
Faulting process id: 0x334
Faulting application start time: 0x01cd47e7356fcba2
Faulting application path: C:\Program Files (x86)\Tor Browser\App\vidalia.exe
Faulting module path: C:\Program Files (x86)\Tor Browser\App\QtCore4.dll
Report Id: c03d00d0-b3db-11e1-b45a-60eb69d93c5d

Both times were when closing the GUI. I believe I clicked the X close button in the Vidalia GUI. I do have EMET running on vidalia.exe with the following protections enabled: DEP, SEHOP, NullPage, HeapSpray, EAF, MandatoryASLR and BottomUpRand. However, the crash is intermittent.

Please let me know if there is anything I can do to help debug.

It also crashed a month ago, but with a different module:

Description
Faulting application name: vidalia.exe, version: 0.2.17.0, time stamp: 0x4f9a1054
Faulting module name: QtNetwork4.dll, version: 4.8.1.0, time stamp: 0x4f6c7758
Exception code: 0xc0000005
Fault offset: 0x0006a188
Faulting process id: 0x120c
Faulting application start time: 0x01cd2d33cc9b3000
Faulting application path: C:\Program Files (x86)\Tor Browser\App\vidalia.exe
Faulting module path: C:\Program Files (x86)\Tor Browser\App\QtNetwork4.dll
Report Id: 705773bb-9928-11e1-b9bd-60eb69d93c5d

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by keystroke

I have more information on this crash. I am now running the Microsoft EMET software and I received the following crash with the EMET message:
"EMET detected DEP mitigation and will close the application: vidalia.exe"

Faulting application name: vidalia.exe, version: 0.2.19.0, time stamp: 0x4fcfd78b
Faulting module name: QtCore4.dll, version: 4.8.1.0, time stamp: 0x4f6c7688
Exception code: 0xc0000005
Fault offset: 0x00249020
Faulting process id: 0x1788
Faulting application start time: 0x01cd611000dd012b
Faulting application path: C:\Program Files (x86)\Tor\App\vidalia.exe
Faulting module path: C:\Program Files (x86)\Tor\App\QtCore4.dll
Report Id: 5ca395ba-cd03-11e1-b88c-60eb69d93c5d

comment:2 Changed 7 years ago by sysrqb

Looks like a dupe of #4009 but with more info. Will investigate.

comment:3 Changed 19 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:4 Changed 12 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.