Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6170 closed defect (fixed)

Metrics graphs glitches

Reported by: asn Owned by: karsten
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Child Tickets

Change History (4)

comment:1 in reply to:  description Changed 7 years ago by karsten

Owner: set to karsten
Status: newassigned

Replying to asn:

https://metrics.torproject.org/users.html?graph=direct-users&start=2012-03-14&end=2012-06-04&country=gq&dpi=72#direct-users

Hmm, you mean the weeks in March and April when the line goes away instead of dropping to zero?

Here's what happened: we don't have a single directory mirror reporting requests from .gq during those weeks, so we treat these dates as "don't have any data" and interrupt drawing the line. This makes sense for times when there was a general problem with statistics gathering in the network; we wouldn't want all graphs to drop to zero in that case. But in this case we know that there was no such network-wide event and we could interpret "no data for .gq, but lots of data for other countries" as "no users from .gq". I'll fix this once I come up with a good idea how to fix it. :)

Just to be sure, this is what you were referring to, right?

https://metrics.torproject.org/users.html?graph=direct-users&start=2012-03-14&end=2012-06-04&country=sy&events=on&dpi=72#direct-users
(the last one is related to the censorship events upscores/downscores graphs)

Fixed.

comment:2 Changed 7 years ago by karsten

Resolution: fixed
Status: assignedclosed

Found a way to fix the first problem. Closing. Please reopen if you think one of the problems is not fixed.

comment:3 Changed 7 years ago by asn

How did you fix the first problem?

Is the 0 in Nov. 2011 of:
https://metrics.torproject.org/bridge-users.png?start=2011-08-01&dpi=72&end=2011-11-30&country=all
caused by the fix?

Are problems with statistics gathering in the network happening frequently?

comment:4 in reply to:  3 Changed 7 years ago by karsten

Replying to asn:

How did you fix the first problem?

See the commit message for a description of the fix.

Is the 0 in Nov. 2011 of:
https://metrics.torproject.org/bridge-users.png?start=2011-08-01&dpi=72&end=2011-11-30&country=all
caused by the fix?

No. I only fixed direct users graphs for single countries, not bridge users from all countries. The 0 (which is actually a 184) comes from too few bridges reporting statistics. We should interrupt that line if there are too few reporting bridges. The much better fix, though, is to work on #5807 for real bridge usage statistics.

Are problems with statistics gathering in the network happening frequently?

With bridges, somewhat, yes. We have 1--2 events when the tor process on Tonga fails, Tonga fails to copy over descriptors to yatei, or something else happens. We have deployed some checks to notice these problems early, but it still happens every now and then.

With relays, rather infrequently.

Note: See TracTickets for help on using tickets.