Opened 15 years ago

Last modified 7 years ago

#62 closed defect (Fixed)

connect attempt just hangs

Reported by: weasel Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: 0.1.0.0-alpha-cvs
Severity: Keywords:
Cc: weasel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

cvs as of 2005-01-13-11:25 utc, on amd64 I notice the following: (I couldn't reproduce that on i386)

torify telnet seppia.noreply.org 80 works the first, and sometimes
the second time, but it never works the 3rd time.

debug log will be attached

[Automatically added by flyspray2trac: Operating System: Other Linux]

Child Tickets

Attachments (2)

debug.log (68.2 KB) - added by weasel 15 years ago.
debug log
log2 (54.7 KB) - added by weasel 15 years ago.
same thing from yesterday. at 04:02:35 it hang

Download all attachments as: .zip

Change History (6)

Changed 15 years ago by weasel

Attachment: debug.log added

debug log

comment:1 Changed 15 years ago by weasel

At 12:45:42 the telnet hang, at 12:49:14 I killed it.

Changed 15 years ago by weasel

Attachment: log2 added

same thing from yesterday. at 04:02:35 it hang

comment:2 Changed 15 years ago by weasel

It is also reproducible on i386 now.

It happens when libevent uses the epoll method, which is available on linux 2.6.x.

comment:3 Changed 15 years ago by nickm

flyspray2trac: bug closed.
Fixed by patch from Adam Langley in connection.c:1.323. We were calling event_del after closing the socket; that
s bad.

comment:4 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.