Opened 12 years ago

Last modified 11 years ago

#623 closed defect (Fixed)

Torbutton breaks Firefox3b4 bookmarks

Reported by: torbert Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.1
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I had installed FireFox 3 beta 4. After using FF3 for a little while
with out torbutton. Upon installing torbutton 1.1.16 and restarting
firefox the bookmarks promptly disappeared. Uninstalling TorButton
resolves the issue.

When torbutton is installed it appear that all writes to the Bookmarks
are blocked, importing or creating new bookmarks are not possible.

Os: Mac OS X 10.4.11 (PPC)
Browser: Firefox 3 beta 4
Torbutton: 1.1.16

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (4)

comment:1 Changed 11 years ago by mmel

I'd like to confirm this bug

Firefox: Mozilla Firefox 3 Beta 4
TorButton: torbutton-1.1.17-alpha.xpi

Other extensions: DownloadThemAll! 1.0, NoScript 1.5.2, Tab Mix Plus 0.3.6.1.080317pre

Please note this bug still appears when no other Extensions are enabled. Disabling/Enabling TorButton 1.1.17 is the only change made to the software to make the bookmarks disappear and come back again. When TorButton is enabled, as torbert mentioned, no writes can be made to bookmarks, no new bookmarks can be made, import/recovery of bookmarks does not work.
I have screenshots demonstrating all the error conditions, but attachments do not appear to be working at the moment ( or I do not have permission to upload).

comment:2 Changed 11 years ago by Devolved

Confirmed.

Firefox: Mozilla Firefox 3 Beta 4
TorButton: torbutton-1.1.17-alpha.xpi

Ubuntu Hardy

comment:3 Changed 11 years ago by crl620

Confirmed on 3b5 too.

Firefox: Mozilla Firefox 3 Beta 5
Torbutton: 1.1.17-alpha

Other Extensions: Firebug 1.1.0b12, Web Developer 1.1.15

Disabling TorButton makes bookmarks reappear. Maybe this is the intended operation for privacy reasons, but it's an unexpected condition right after installing tor.

comment:4 Changed 11 years ago by mikeperry

flyspray2trac: bug closed.
Should be fixed in 1.2.0rc3, possibly even rc1 or rc2.. I think this was an issue in the hooking code, which was fixed early on in the 1.2.0rc series. Anyways, it seems to work for me now.

Note: See TracTickets for help on using tickets.