Opened 7 years ago

Closed 13 months ago

#6259 closed defect (wontfix)

Vidalia can't start Tor: Couldn't access/create private data directory "/usr/bin"

Reported by: akwala Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Tor: 0.2.3.20-rc
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Jun 30 01:45:46.917 [Notice] Tor v0.2.3.18-rc (git-a2015428e4698ff9) running on Linux.
Jun 30 01:45:46.917 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jun 30 01:45:46.978 [Notice] Read configuration file "/home/myname/.vidalia/torrc".
Jun 30 01:45:47.195 [Notice] Initialized libevent version 2.0.12-stable using method epoll (with changelist). Good.
Jun 30 01:45:47.195 [Notice] Opening Socks listener on 127.0.0.1:9050
Jun 30 01:45:47.195 [Notice] Opening Control listener on 127.0.0.1:9051
Jun 30 01:45:47.195 [Notice] Opening OR listener on 0.0.0.0:9001
Jun 30 01:45:47.195 [Warning] /usr/bin is not owned by this user (myname, 1000) but by root (0). Perhaps you are running Tor as the wrong user?
Jun 30 01:45:47.195 [Warning] Failed to parse/validate config: Couldn't access/create private data directory "/usr/bin"
Jun 30 01:45:47.195 [Error] Reading config failed--see warnings above.

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #6178.

comment:2 in reply to:  1 ; Changed 7 years ago by akwala

Replying to rransom:

Duplicate of #6178.

The comment on the Duplicate (#6178) seems to attribute this to the absence of the default datadir ~/.vidalia/. In my case this directory does exist as does ~/.vidalia/torrc, which I've been using. I also have ~/.tor that does not contain torrc, but there is /etc/tor/torrc in which all options are commented out (which I assume means that their default values will be used). Given this, not sure why /usr/bin is being looked at as a location for the data directory.

comment:3 in reply to:  2 Changed 7 years ago by consultit

Replying to akwala:

Replying to rransom:

Duplicate of #6178.

The comment on the Duplicate (#6178) seems to attribute this to the absence of the default datadir ~/.vidalia/. In my case this directory does exist as does ~/.vidalia/torrc, which I've been using. I also have ~/.tor that does not contain torrc, but there is /etc/tor/torrc in which all options are commented out (which I assume means that their default values will be used). Given this, not sure why /usr/bin is being looked at as a location for the data directory.

I have exactly the same problem after updating tor in my debian squeeze from deb.torproject.org. Before all worked fine and during update I left all configuration unchanged. Btw I tried to reinstall tor + vidalia but the same error is present:
...
/usr/bin is not owned by this user (consultit, 1000) but by root (0). Perhaps you are running Tor as the wrong user?
Failed to parse/validate config: Couldn't access/create private data directory "/usr/bin"
...

comment:4 Changed 7 years ago by cypherpunks

With Vidalia 0.2.19 and Tor 0.2.3.18-rc, it may be possible to fix this issue by adding a line like the following to the ~/.vidalia/vidalia.conf file in the [Tor] section:

DataDirectory=~/.vidalia/data

comment:5 Changed 7 years ago by akwala

Resolution: duplicate
Status: closedreopened
Version: Tor: 0.2.3.18-rcTor: 0.2.3.20-rc

Reopening this because the issue persists even though it's marked as a duplicate of another bug that's apparently fixed -- I suspect this is a separate issue, not a duplicate; please read the preceding comments.

===

Aug 17 14:46:03.252 [Notice] Tor v0.2.3.20-rc (git-8a06c87d156f4335) running on Linux.Aug 17 14:46:03.252 [Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warningAug 17 14:46:03.252 [Notice] Read configuration file "/home/myname/.vidalia/torrc".Aug 17 14:46:03.263 [Notice] Initialized libevent version 2.0.16-stable using method epoll (with changelist). Good.Aug 17 14:46:03.263 [Notice] Opening Socks listener on 127.0.0.1:9050Aug 17 14:46:03.264 [Notice] Opening Control listener on 127.0.0.1:9051Aug 17 14:46:03.264 [Notice] Opening OR listener on 0.0.0.0:9001Aug 17 14:46:03.264 [Warning] /usr/bin is not owned by this user (myname, 1000) but by root (0). Perhaps you are running Tor as the wrong user?Aug 17 14:46:03.264 [Warning] Failed to parse/validate config: Couldn't access/create private data directory "/usr/bin"Aug 17 14:46:03.264 [Error] Reading config failed--see warnings above.

comment:6 Changed 20 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:7 Changed 13 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: reopenedclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.