Opened 7 years ago

Closed 7 years ago

#6270 closed defect (fixed)

tomcat6 on yatei out of memory heap error

Reported by: phobos Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

tomcat6 keeps generating these errors from onionoo, which eventually crashed tomcat:
{{
Jul 1, 2012 10:43:06 AM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet Resource threw exception
java.lang.OutOfMemoryError: Java heap space

at java.util.Arrays.copyOf(Arrays.java:2894)
at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:117)
at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:407)
at java.lang.StringBuilder.append(StringBuilder.java:136)
at java.lang.StringBuilder.append(StringBuilder.java:184)
at java.lang.StringBuilder.append(StringBuilder.java:72)
at java.util.Formatter$FormatSpecifier.print(Formatter.java:2839)
at java.util.Formatter$FormatSpecifier.printString(Formatter.java:2812)
at java.util.Formatter$FormatSpecifier.print(Formatter.java:2693)
at java.util.Formatter.format(Formatter.java:2449)
at java.util.Formatter.format(Formatter.java:2383)
at java.lang.String.format(String.java:2781)
at org.torproject.onionoo.ResourceServlet.formatRelaySummaryLine(ResourceServlet.java:129)
at org.torproject.onionoo.ResourceServlet.readSummaryFile(ResourceServlet.java:76)
at org.torproject.onionoo.ResourceServlet.getLastModified(ResourceServlet.java:145)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:613)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:636)

}}

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by karsten

Resolution: fixed
Status: newclosed

It looks like this problem was caused by the June 30/July 1 Java leap second bug. Restarting yatei seems to have solved the problem... I'll keep an eye on the logs the next days, and if the problem happens again, will re-open. Closing for now.

Note: See TracTickets for help on using tickets.