Opened 7 years ago

Closed 7 years ago

#6275 closed defect (fixed)

GetTor statistics are not updated since June 3

Reported by: karsten Owned by: kaner
Priority: Medium Milestone:
Component: Applications/GetTor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Today, I noticed that

http://gettor.torproject.org:8080/~gettor/gettor_stats.txt

ends on June 3. Is the GetTor process still running? If so, is there some other problem with updating the gettor_stats.txt file?

Child Tickets

Change History (9)

comment:1 Changed 7 years ago by kaner

Status: newaccepted

GetTor is still running. There is a problem with the stats script. I'm looking into it right now. (Also, I need to finish the move from dnsel2 to getulum asap)

comment:2 Changed 7 years ago by kaner

Resolution: fixed
Status: acceptedclosed

Fixed a minor parsing issue. The stats script is working again. Thanks for the notification.

comment:3 Changed 7 years ago by karsten

Resolution: fixed
Status: closedreopened

Hmm, the stats file now contains a few invalid lines. Can you fix those? Otherwise I'd try to work around those.

2012-06-20 - None:240 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 lin[...]
 - None:0 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 linux-i386_en:0[...]
 - None:0 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 linux-i386_en:0[...]
 - None:0 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 linux-i386_en:0[...]
 - None:0 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 linux-i386_en:0[...]
2012-06-25 - None:1463 linux-i386:0 linux-i386_ar:0 linux-i386_de:0 li[...]

Thanks!

comment:4 Changed 7 years ago by kaner

Ok, i'll take a look

comment:5 Changed 7 years ago by karsten

metrics-web sends me a warning email every hour because of the invalid GetTor statistics file. I just disabled importing the GetTor file. Please let me know when this problem is fixed on GetTor's side and I'll re-enable importing the file on metrics-web's side. Thanks.

comment:6 Changed 7 years ago by kaner

What exactly is broken with those lines? I looked them up in the stats file, compared stats to actual log file and they seem legit. Sorry, I must be overseeing something obvious. :-)

comment:7 Changed 7 years ago by kaner

Ah, whoops. As soon as I hit "Submit", I saw what the problem is. Will check.

comment:8 Changed 7 years ago by kaner

I know what the problem is, but won't fix it today. I'll let you know when to have a test run (maybe tomorrow).

comment:9 Changed 7 years ago by karsten

Resolution: fixed
Status: reopenedclosed

Looks like it's working again. There are a few missing days in the statistics file, resulting from no packages being requested from GetTor as kaner says, but that's fine. Closing. Thanks, kaner!

Note: See TracTickets for help on using tickets.