Opened 7 years ago

Closed 7 years ago

#6280 closed defect (fixed)

https-everywhere.js:434 - lst is null

Reported by: grarpamp Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While attempting to browse a site (pof.com, www.pof.com) that
sends back on its https port certs that need manual acceptance
and then 302's back to http... and somewhere in that fallback
redirect loop Firefox error console says:

'lst is null'
extensions/https-everywhere@…/components/https-everywhere.js
line 434

ff 10.0.3 esr
https-e 2.1

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by pde

Resolution: fixed
Status: newclosed

That's a particularly hacky code path.  It attempts to work out which windows requests pertain to in order to poplulate the HTTPS Everywhere context menu correctly.  Although I can't reproduce this error, I'm not totally surprised that it happens and it could do nasty things to the UI.

It therefore makes sense to handle a null value for lst more gracefully.  Done.

Note: See TracTickets for help on using tickets.