Opened 7 years ago

Closed 6 years ago

#6281 closed enhancement (duplicate)

How many relay operators are using Weather?

Reported by: runa Owned by:
Priority: Medium Milestone:
Component: Metrics/Analysis Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I think it would be good to have some stats for how popular Weather is, how many relay operators use it, and so on.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by karsten

Component: Metrics Data ProcessorAnalysis

The goal here is to learn if we can shut down Weather without making too many relay operators sad? In one of the summer dev meeting sessions yesterday afternoon we decided to find a maintainer for Weather and keep it running. Still, having some usage data might help us decide on the priority to finding a maintainer.

I could imagine gathering two stats here:

  • Number of relay operators (un-)registering every day. We can probably learn that from (sanitized) weblogs. Adding Weather's logs to webstats and looking at webalizer output might tell us what we want to know.
  • Number of registered relays and number of such relays which were active in the past month. If someone can give me a dump of relay fingerprints in the database, I can compare that to the consensuses and output the two numbers.

Would that help?

comment:2 Changed 6 years ago by karsten

Resolution: duplicate
Status: newclosed

Closing as near-duplicate of #10699.

Note: See TracTickets for help on using tickets.