Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6299 closed defect (not a bug)

Are consensus weights supposed to be zero?

Reported by: karsten Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-auth
Cc: gsathya, nickm, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

gsathya brought up the question why there are consensus weights of 0. I looked up consensus published in the first half of 2012. There are 4.9 relays with consensus weight 0 in the mean. Does that mean that these relays are never picked by clients? Is it supposed to be like this?

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by karsten

Cc: gsathya nickm mikeperry added

Nick suggested to also look at bandwidth values in the votes. The two relays with consensus weight 0 in the most recent consensus have no measured bandwidths in votes. The directory authorities are using the self-reported bandwidth of 0. Maybe it's okay to leave their consensus weight at 0 if they're not measured and they say about themselves that they don't have any bandwidth to contribute. Nick adds that there's a pending patch that Mike is going to revise to make authorities behave differently about not-yet-measured relays.

comment:2 Changed 7 years ago by mikeperry

If a relay somehow manages to self-report a 0 value, the bandwidth auths will never be able to weight that relay higher than 0, because the weights are calculated by multiplying the measured stream bandwidth ratio of the relay by the reported value.

comment:3 Changed 7 years ago by karsten

Resolution: not a bug
Status: newclosed

Sounds like consensus weights being zero isn't something to worry about, at least not very much, right? Closing this ticket. If we should worry about weights, please somebody reopen this ticket.

comment:4 Changed 7 years ago by nickm

Keywords: tor-auth added

comment:5 Changed 7 years ago by nickm

Component: Tor Directory AuthorityTor
Note: See TracTickets for help on using tickets.