Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6312 closed defect (wontfix)

check.torproject.org might give false sense of anonymity

Reported by: bpmcontrol Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

while running an exit node, check.torproject.org tells me that I'm using Tor even from a browser that's not using Tor, and even on my phone, which isn't using Tor.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by cypherpunks

Resolution: not a bug
Status: newclosed

comment:2 Changed 7 years ago by zZzz

Resolution: not a bug
Status: closedreopened

Perhaps it should be made more obvious that it is an "estimation" (it's said so on a few other places, IIRC). I do think this could be a (minor) issue, however. Not a big deal, on the otherhand.

comment:3 Changed 7 years ago by phobos

Resolution: wontfix
Status: reopenedclosed

this is a known risk and we assume exit relay operators are smart enough to understand it.

comment:4 Changed 7 years ago by bpmcontrol

point taken, and i hate to be annoying.
especially to you guys who do such important work.
and anyway people can just use amazon since it distinguishes
between a browser using Tor and another instance not using it even on an exit node.
but perhaps just a little change to the line
"You are now free to browse the Internet anonymously."?
if i have annoyed you, please just erase this user and don't own my box.

Note: See TracTickets for help on using tickets.