Opened 5 years ago

Closed 5 years ago

#6337 closed defect (fixed)

deactivate Check for new messages every 10 minutes

Reported by: proper Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: proper@…, sukhbir.in@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I think leaving Check for new messages every 10 minutes by default is a bad choice. If the users wants this, he should activate it.

It adds unnecessary load to Tor if the user left his desktop for a while or simply forgot to close Thunderbird. Checking every 10 minutes lets the mail provider guess how long a Tor session lasted. Its better to pull mails only on demand and cease any unnecessary transmissions afterwards.

Child Tickets

Change History (23)

comment:1 Changed 5 years ago by proper

Cc: proper@… added

comment:2 in reply to:  description ; Changed 5 years ago by arma

Replying to proper:

It adds unnecessary load to Tor if the user left his desktop for a while or simply forgot to close Thunderbird.

Right. We really want to avoid Tor packages that use Tor the whole time whether the user is around or not -- it means the directory fetching can never go idle.

Checking every 10 minutes lets the mail provider guess how long a Tor session lasted.

Also a good point.

comment:3 Changed 5 years ago by sukhbir

This has been fixed in the latest commit, where we disable checking for new messages automatically and also preventing Thunderbird from checking for new messages at startup. We are disabling this for already configured accounts and new accounts that will be created using the manual account configuration in TorBirdy.

comment:4 Changed 5 years ago by sukhbir

Resolution: fixed
Status: newclosed

I am going to mark this as fixed. Please test this in the new release (coming soon!).

comment:5 Changed 5 years ago by lstrtstr

While I agree that deactivating it by default is absolutely right, I think it is annoying as hell that I cannot override it permanently. I have certain accounts which I definitely want to check every so many minutes. However, if I activate the setting, TorBirdy will deactivate it again at Thunderbird restart, forcing me to do it over and over again every session. I might be the only one, but this really annoys me.
Couldn't it be made possible to override this setting and maybe serve a warning dialog letting the user choose if the setting should last for that session only or until deactivated again manually?

comment:6 Changed 5 years ago by proper

Resolution: fixed
Status: closedreopened

Agreed with lstrtstr. Manually overrirding should always be possible but that is now forbidden.

Related to #6441 #6336 #6337.

comment:7 Changed 5 years ago by tagnaq

I agree, a user should be free to opt-out of the default more privacy preserving mode.
Maybe adding a warning box to inform the user on the side effects, when the user chooses to check emails automatically every x minutes.

comment:8 Changed 5 years ago by sukhbir

How do you want this to be handled? Can the user opt-in/opt-out on a per-account basis or globally for all accounts? (I think per-account should be fine but just confirming).

comment:9 in reply to:  description Changed 5 years ago by rransom

Replying to proper:

Checking every 10 minutes lets the mail provider guess how long a Tor session lasted. Its better to pull mails only on demand and cease any unnecessary transmissions afterwards.

Only checking for new messages on demand leaks information about when a user is sitting in front of its computer (and thus probably also using a web browser). Allowing a user to check for new messages on demand at all can leak information about whom a user is communicating with in real time.

comment:10 Changed 5 years ago by ioerror

I think it was Nick or Roger who I discussed this with at PETS. I forget, so I take responsibility for this - but if one of them would chime in, I'd appreciate it!

My take is simple - we should add an option to check messages regularly. That option should take a window, randomly pick a time for that window and check the time in that window. So for example:

new time window every ten minutes - check it at a random time inside that ten minute window, sometimes it will be instantly, sometimes it will be at the end of the ten minute window. That should ensure that you have at most checked messages every twenty minutes.

Thoughts?

comment:11 in reply to:  2 Changed 5 years ago by rransom

Replying to arma:

Replying to proper:

It adds unnecessary load to Tor if the user left his desktop for a while or simply forgot to close Thunderbird.

Right. We really want to avoid Tor packages that use Tor the whole time whether the user is around or not -- it means the directory fetching can never go idle.

This issue isn't so bad if the user points an automatically fetching MUA at a Tor client that also runs (some of) their home remote-access hidden services. (But Thunderbird can't be used that way, because it's a one-piece GUI monster.)

comment:12 in reply to:  8 Changed 5 years ago by lstrtstr

Replying to sukhbir:

How do you want this to be handled? Can the user opt-in/opt-out on a per-account basis or globally for all accounts? (I think per-account should be fine but just confirming).

Personally, I think per-account would be best.

comment:13 in reply to:  10 Changed 5 years ago by lstrtstr

Replying to ioerror:

I think it was Nick or Roger who I discussed this with at PETS. I forget, so I take responsibility for this - but if one of them would chime in, I'd appreciate it!

My take is simple - we should add an option to check messages regularly. That option should take a window, randomly pick a time for that window and check the time in that window. So for example:

new time window every ten minutes - check it at a random time inside that ten minute window, sometimes it will be instantly, sometimes it will be at the end of the ten minute window. That should ensure that you have at most checked messages every twenty minutes.

Thoughts?

Sounds great.

comment:14 Changed 5 years ago by sukhbir

In 0.0.11, we allow you to manually set this on per-account basis. We have not implemented Jake's suggestion but we plan to in the next release.

comment:15 Changed 5 years ago by lstrtstr

Unfortunately, this does not seem to work as expected.

When I try to change the Account Specific settings in the Torbirdy preferences, I cannot save them. I hit "Save", but nothing happens. (No error message in the terminal or js console - just nothing happens.) The dialog window does not close (and if I close it manually, the settings are not saved.)

However, I can set this (and the "check at startup setting", see #6336 ) in the normal Thunderbird Account Settings now, and the settings remain persistent.
That is not how it is supposed to work, though, right?

There seems to be another glitch in the Account Specific settings. When "Check for new messages every" is checked, the number of minutes is grayed out and cannot be changed. When it is unchecked, the number can be changed. Shouldn't it be the other way around?

comment:16 in reply to:  15 ; Changed 5 years ago by sukhbir

Replying to lstrtstr:

Unfortunately, this does not seem to work as expected.

I can't seem to reproduce this any of the issues you described.

When I try to change the Account Specific settings in the Torbirdy preferences, I cannot save them. I hit "Save", but nothing happens. (No error message in the terminal or js console - just nothing happens.) The dialog window does not close (and if I close it manually, the settings are not saved.)

The dialog window should close and the settings should be saved.

However, I can set this (and the "check at startup setting", see #6336 ) in the normal Thunderbird Account Settings now, and the settings remain persistent.
That is not how it is supposed to work, though, right?

You can set privacy settings through the Thunderbird Account settings if you want to (we override them only on TorBirdy install) but TorBirdy's preferences dialog can handle those.

There seems to be another glitch in the Account Specific settings. When "Check for new messages every" is checked, the number of minutes is grayed out and cannot be changed. When it is unchecked, the number can be changed. Shouldn't it be the other way around?

It is the way it should be -- checked : allow changing minutes, unchecked : disable changing minutes.

So something is causing TorBirdy to cause an error and perhaps that is why you have the issues that you described.

Can you please:

  1. check which version of TorBirdy are you using? (Latest: 0.0.11)
  2. watch the JS console for errors when you perform the above actions
  3. let us know which version of Thunderbird are you using?

comment:17 in reply to:  16 Changed 5 years ago by lstrtstr

Replying to sukhbir:

So something is causing TorBirdy to cause an error and perhaps that is why you have the issues that you described.

Can you please:

  1. check which version of TorBirdy are you using? (Latest: 0.0.11)
  2. watch the JS console for errors when you perform the above actions
  3. let us know which version of Thunderbird are you using?
  1. Using TorBirdy 0.0.11. Shasum matches.
  2. No errors on the JS console.
  3. Icedove 10.0.6

comment:18 Changed 5 years ago by ioerror

Do you have any other plugins/extensions installed?

comment:19 in reply to:  18 ; Changed 5 years ago by lstrtstr

Replying to ioerror:

Do you have any other plugins/extensions installed?

Yes, but I already tried it with everything else disabled, and I tried it with a fresh profile. The problems/glitches were the same.

comment:20 in reply to:  19 ; Changed 5 years ago by sukhbir

Cc: sukhbir.in@… added

Replying to lstrtstr:

Replying to ioerror:

Do you have any other plugins/extensions installed?

Yes, but I already tried it with everything else disabled, and I tried it with a fresh profile. The problems/glitches were the same.

lstrtstr: It was a bug, a big one! Thanks for reporting this. Please generate a XPI from the repository and try it now. (A new release should be available soon).

comment:21 in reply to:  20 ; Changed 5 years ago by lstrtstr

Replying to sukhbir:

lstrtstr: It was a bug, a big one! Thanks for reporting this. Please generate a XPI from the repository and try it now. (A new release should be available soon).

I just built it, and it works!
What was it? How did you reproduce it?

comment:22 in reply to:  21 Changed 5 years ago by sukhbir

Replying to lstrtstr:

Replying to sukhbir:

lstrtstr: It was a bug, a big one! Thanks for reporting this. Please generate a XPI from the repository and try it now. (A new release should be available soon).

I just built it, and it works!
What was it? How did you reproduce it?

I was not able to reproduce it when I tried to, I noticed this by chance. I was checking the layout of TorBirdy dialogs in a Windows VM and observed the issues you described and so I investigated on the basis of that. There was an 'accounts is not defined' error in the error console and I found the issue was due to improper loading of account configurations. Glad it is fixed, it was a critical bug :)

comment:23 Changed 5 years ago by sukhbir

Resolution: fixed
Status: reopenedclosed

I am closing this ticket. We fixed this in 0.0.12 and the user can opt-out in for automatic email checking and set a desired time interval. This can be set from the preferences dialog (and not through Thunderbird settings, TorBirdy will overwrite those), so we do warn the user in case this will be changed from the default of "don't check for new messages automatically". Jake's solution is good but that will introduce more complexity, such as having a configuration option for each account and thus complicating matters more. So let's go with the current approach only, it seems to be working well; most users will let TorBirdy handle this setting, and those who want to change can do so.

Note: See TracTickets for help on using tickets.