Opened 7 years ago

Closed 7 years ago

#6340 closed defect (fixed)

TBB can`t start Firefox after Arch Linux update

Reported by: cypherpunks Owned by: erinn
Priority: Very High Milestone: TorBrowserBundle 2.2.x-stable
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: flavioamieiro@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After recent update of glibc package (I suupose) in my Arch Linux x86_64, Firefox in TBB can not be started. Terminal tells about segfault error. /var/log/messages.log is full of something like this:
Jul 6 19:11:51 host kernel: [ 3604.899773] firefox[5141]: segfault at 7f3fe7204dc8 ip 00007f3e822368a3 sp 00007ffffa69ce20 error 4 in ld-2.16.so[7f3e8222b000+21000]

Child Tickets

Attachments (1)

0001-Disables-the-ELF-hack-as-a-workaround-for-6340.patch (853 bytes) - added by amieiro 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:2 Changed 7 years ago by amieiro

Cc: flavioamieiro@… added

I can confirm this bug, and I couldn't even build TBB without getting a segfault.

After some digging I found this https://bugzilla.mozilla.org/show_bug.cgi?id=770819 and this https://bugzilla.mozilla.org/show_bug.cgi?id=771569.

I looks like a glibc bug interacts badly with a hack that Firefox pulls on the ELF structure (apparently to speed things up: http://sourceware.org/bugzilla/show_bug.cgi?id=14341#c0).

Mozilla appears to have fixed this in 10esr (https://hg.mozilla.org/releases/mozilla-esr10/rev/2ffb11d8b2f8), so we should have a fix for this when we update to 10.0.6.

Anyway, I am building TBB now with --disable-elf-hack to see if it fixes the issue.

comment:3 Changed 7 years ago by amieiro

Ok, a TBB built with --disable-elf-hack works fine here in Archlinux with glibc
2.16, so this looks to be the workaround. I attached the dot_mozconfig patch.

I don't know if this patch should be included in the official TBB though, since
the issue will be fixed in the next minor version of Firefox (and possibly also
in glibc).

comment:4 Changed 7 years ago by amieiro

Now that Firefox 10.0.6 was released, I can confirm that it indeed fixes this issue.

comment:5 Changed 7 years ago by amieiro

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.