Opened 7 years ago

Closed 7 years ago

#6368 closed defect (fixed)

HTTPS Everywhere 2.1 Yahoo mail login

Reported by: dudidi Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: Yahoo mail
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get a message that my email or my password is incorrect, when HTTPS Everywhere is enabled, even though it's disabled for Yahoo mail. Even though HTTPS Everywhere is set by default not to work on Yahoo mail, I still can't log-in, despite the fact that I see that HTTPS Everywhere is set not to work on Yahoo mail (with a red X mark next to "Yahoo Mail (buggy)" and "Yahoo Mail 4 (experimental)")!
The only way I can log-in using Firefox 12, is by disabling the add-on all together.
It's strange that I have an HTTPS Everywhere version for Google Chrome and it never does this problem.
I don't like to disable the add-on all together every time I wanted to log-in to my Yahoo mail.

Looks like "eilegz" had the same problem. I found a link next to the "Yahoo Mail (buggy)" in the list on HTTPS Everywhere: https://eff.org/r.G7u
I'm using Firefox 12 on Windows 7. Supposedly it's a problem only encountered by older versions of Firefox, I have to point out that I can't use Firefox 13 and newer stable versions up till now because they have a defect which make them display oblique fonts quite illegible.

By the way, I know how to disable specific sites from using HTTPS from HTTPS Everywhere and I silently did it for some sites, such as for Google Services because it stopped translate.google.com from translating URLs.

Child Tickets

Change History (8)

comment:1 Changed 7 years ago by pde

I haven't been able to reproduce this problem.  Can you do HTTPS Everywhere button -> Enable / Disable rules -> Reset to Defaults, and see if it persists?  Or if you don't want to change which rulesets are enabled and disabled, you could create a new Firefox profile, install HTTPS Everywhere in that, and test using that browser.

comment:2 Changed 7 years ago by arma

The person replied to the trac email, rather than posting an answer. Here it is:

The link you gave me to show me how to create a new profile on Firefox does not
work, even though I tried too many times and waited for a while. It tells me:
ERRORThe requested URL could not be retrieved
While trying to retrieve the URL:
http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

The following error was encountered:



Connection Failed


The system returned:
    (110) Connection timed out
The remote host or network may be down.  Please try the request again.
Your cache administrator is root.

Generated Tue, 17 Jul 2012 12:56:11 GMT by sunrise-squid.mz.osuosl.org (squid/2.5.STABLE11)

Today, I tried to log-in to Yahoo, it showed me the same error, as if my email
or password was wrong, then after waiting for a moment, it entered the email
page.
I restored the default settings of HTTPS Everywhere as you advised me, nothing
changed from what happened to me in the previous sentence.
But, when I disable the HTTPS Everywhere from the option in the tools menu (as I
did in the original post), I log-in immediately, as I explained in the original
post, last week.

comment:3 Changed 7 years ago by pde

Perhaps that mozillazine webserver was down briefly? If it still doesn't work, you could also try the Google Cache cop of the page.

comment:4 Changed 7 years ago by pde

"cop" → "copy"

comment:5 in reply to:  3 Changed 7 years ago by dudidi

Replying to pde:

Perhaps that mozillazine webserver was down briefly? If it still doesn't work, you could also try the Google Cache cop of the page.

Thanks pdr and arma.
No need now to open kb.mozillazine.org, as I made the settings to the defaults. The site works right now, anyway.
The problem which I explained in the post which I sent via email still exists.

comment:6 Changed 7 years ago by dudidi

Priority: majornormal

comment:7 Changed 7 years ago by pde

Dudidi, am I correct in understanding that you made a new profile, and the bug was still present? Resetting to defaults may not be enough, because it is possible that this is an interaction between HTTPS Everywhere and another Firefox addon/extension.

comment:8 Changed 7 years ago by schoen

Resolution: fixed
Status: newclosed

My understanding is that "The problem which I explained in the post which I sent via email" is the problem with kb.mozillazine.org, while the site that works right now is a reference to Yahoo! Mail.

Note: See TracTickets for help on using tickets.