Opened 5 years ago

Closed 5 years ago

#6446 closed enhancement (fixed)

create end user documentation / document setup/requirements

Reported by: tagnaq Owned by: tagnaq
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords: 2012-09-30
Cc: sukhbir.in@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As recently seen on tor-talk [1] it is not clear to end users* how to use TorBirdy, especially what requirements come with it.

We should create an end user quick setup howto for TorBirdy. When such questions [1] come up we can point to that page.

https://trac.torproject.org/projects/tor/wiki/torbirdy

[1]
https://lists.torproject.org/pipermail/tor-talk/2012-July/024900.html
https://lists.torproject.org/pipermail/tor-talk/2012-July/024904.html

*) TBH TorBirdy is not end-user ready yet but we should create that page anyway.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by tagnaq

more instances on docu req:
https://lists.torproject.org/pipermail/tor-talk/2012-August/025406.html
https://lists.torproject.org/pipermail/tor-talk/2012-August/025411.html

Short TorBirdy Installation Guide

This short guide should help you to setup your Thunderbird email client to send and fetch email via Tor.
It can be used for new or already existing email accounts. Bear in mind that email accounts
that have been used without Tor before offer less privacy/anonymity/weaker pseudonyms than email account that have been 
created using TorBrowser and have never been accessed without Tor, but 
TorBirdy is still useful for exiting accounts or real name email addresses especially if you are looking for location anonymity, i.e. you travel a lot and don't want to disclose all your locations by sending emails. TorBirdy works with SMTP and IMAP/POP3 but POP3 is recommended over IMAP.


Required Software

- Tor (e.g. via "Vidalia Bundle" or "Expert Bundle" )
- Thunderbird 
- TorBirdy Addon

TorBirdy does not require a running instance of the TorBrowser Bundle (TBB) and with default config does not conflict with that instance because TBB chooses random ports for SocksPort and ControlPort.

recommended (optional): 
We recommend the use of end-to-end encrypted email using OpenPGP/Enigmail. 
The configuration of GPG and Enigmail is beyond the scope of this short user guide for TorBirdy.

Setup Steps

1. 
a) Windows/OSX: Download [1] and install the Vidalia Bundle and make sure Tor is running and listening on 127.0.0.1 on port 9050 (default config)
b) GNU/Linux: install Tor with your system package management system and make sure Tor is running on port 9050 (default config)

2. Open Thunderbird's Add-ons configuraton (Tools -> Add-ons) and type "torbirdy" into the search box on the right hand side
3. then click "Install"

Verify Setup

After everything is setup try to send yourself an email and fetch it afterwards. 


[1] https://www.torproject.org/download/download.html.en
[2] https://www.mozilla.org/thunderbird/
[3] https://addons.mozilla.org/en-us/thunderbird/addon/torbirdy/
[4] https://addons.mozilla.org/en-us/thunderbird/addon/enigmail/
------

Troubleshooting
If things don't work for you:

1. make sure Tor is running and listening on 127.0.0.1 (localhost) on port 9050 
2. inspect Vidalia while sending/fetching emails and confirm that something is trying to use the Tor instance to connect to an POP3/IMAP port.

TODO:

  • automatic+reoccurring email fetching
  • HTTP proxy
  • how to permanently run a tor instance on Windows/OSX (tor daemon instance for TorBirdy)

comment:2 Changed 5 years ago by sukhbir

Cc: sukhbir.in@… added

comment:3 Changed 5 years ago by tagnaq

Keywords: 2012-09-30 added
Status: newaccepted

comment:4 Changed 5 years ago by tagnaq

Status: acceptedneeds_review

please review https://trac.torproject.org/projects/tor/wiki/torbirdy

Especially:

We dropped Enigmail support for now to be able to drop the HTTP proxy requirement.

comment:5 Changed 5 years ago by sukhbir

Hi,

I think it's perfect; I just made a few cosmetic changes to it. Do you think I should do a manual for:

a). setting up accounts manually,
b). applying our patches to a custom Thunderbird build.

I was also thinking of adding a "debugger mode" which will be helpful in diagnosing connection issues by generating information about accounts -- ports being used, connection security, etc., which the user can copy and send the report to us. How good/ bad an idea is this? (Note: we just generate the information, what the user wants to send is up to him/her). Because we get issues like TorBirdy is not working with $FOO and we have to request for the information, which never progresses, so the issue is not resolved. Seems like an overkill but I thought it was a good idea.

comment:6 Changed 5 years ago by tagnaq

Resolution: fixed
Status: needs_reviewclosed

I think it it overkill to ask users to apply our patches (msgid +date) and "experts" know how to do it anyway. (Regarding the debugger mode I'd ask you to open a new ticket if you want to implement it).

I think the original goal of this ticket was met and the ticket can be flagged as 'fixed' now,
if you disagree please reopen.

Note: See TracTickets for help on using tickets.