Opened 5 years ago

Closed 5 years ago

#6451 closed enhancement (fixed)

add proxy / tor connectivity check

Reported by: proper Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: proper Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Please let TorBirdy, when enabled, open https://check.torproject.org/ to confirm it's connected over Tor. (Using Thunderbird own html rendering, just like Get Add-Ons is doing as well.)

Related thread:
https://lists.torproject.org/pipermail/tor-talk/2012-July/024935.html

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by tagnaq

Summary: add proxy / tor connectivity checkadd proxy / tor connectivity check / mail header check
Type: defectenhancement

write a mail header verifier-bot (SMTP check)
use case #1
(this is more or less a setup and test once use case)

a user installed torbirdy in his thunderbird and wants to verify that everything
is setup correctly.
the user sends an email to torbirdy-check@...
with his thunderbird and gets an auto-reply which contains
the result of an automated header analysis:

Content-Type: pass
*Date: pass (a hard one)
*Message-ID: pass
EHLO argument: pass
source IP address (exit node): pass
(optional) Enigmail/GPG: pass

  • gpg sign the answer
  • return only PASS if all checks are passed successfully.

*) upcoming feature

I could even immagine the following:
tor-* subscriber is using torbirdy and wants to know when his outgoing
email headers seem to leak something / don't look like torbiry's header, he subscribes
to 'inspect my mail headers for privacy leaks' - service.
torbirdy-check@... is subscribed to tor-*
and automatically inspects all emails from the service subscribers and sends out alerts
as soon as it detected something fishy.

such a mail bot could even be used for automated regression testing.

The check is SMTP specific but there is no possibility that one can configure separate proxies for SMTP and POP3,
so I'm pretty confident that one uses POP3 over Tor if he used SMTP over Tor (default Thunderbird+TorBirdy setup).

comment:2 Changed 5 years ago by proper

tagnaq, would it be worth to split your and my proposal?

Your proposal is a very good one and could also be used to check compatibility with other addons. Although implementation will probable require more effort.

My proposal is probable simpler and faster to implement. I don't think it's a this or this proposal. Both proposals make sense. My proposal aims to help with basic issues, connectivity, such as #6440 (no error message if proxy is unreachable), while your proposal diagnoses the fingerprinting issues.

comment:3 Changed 5 years ago by ioerror

I'm not a fan of this feature at all. It requires a lot of infrastructure for basically no gain.

If we want to check if we're using Tor, I propose we incorporate the TorCheck code from Torbutton that hits check.torproject.org and queries it. We added a very light weight query string that will return a very small bit of text to parse. I don't think it should be automatic but if someone wants a button to check, I support that kind of check/button.

The rest of the stuff sounds like a nightmare to run and we'd then have to manage a key, etc - building that kind of infrastructure seems like a cumbersome solution where an attacker can just lie to give users a false sense of security. They in theory would require the gpg key but since it would be signing stuff - we'd need to keep it online. This is unlike the current key that I use to sign TorBirdy which is kept offline.

I also feel that it might make sense to give Tor a special hostname, where we check the response - I see no reason why we can't extend Tor to give us a bit of detail that doesn't send network traffic. In theory, we can use the control port but I don't think thunderbird needs access to a control port for more than a "is Tor working" and a "did we just use Tor properly" feedback loop.

Another key point is that an attacker can transparently route a non-torified client into the Tor network and all of the above checks would _work_ and no one would be the wiser...

comment:4 in reply to:  2 Changed 5 years ago by tagnaq

Summary: add proxy / tor connectivity check / mail header checkadd proxy / tor connectivity check

Replying to proper:

tagnaq, would it be worth to split your and my proposal?

yes, sorry for misusing this ticket for that input. So lets ignore my input and
discuss the point that was first requested/proposed.

comment:5 Changed 5 years ago by sukhbir

Resolution: fixed
Status: newclosed

(See #6440 also)

Fixed.

Note: See TracTickets for help on using tickets.