Opened 7 years ago

Closed 7 years ago

#6478 closed defect (duplicate)

Vidalia was unable to connect to tor. (connection refused by peer.)

Reported by: Torguy01 Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello, recently Tor browser has stopped working for me and now everytime I try to run it I get "Vidalia was unable to connect to tor. (connection refused by peer.)" From a user-perspective, I made NO changes.

I have not changed any settings on Tor.

I am running the latest version of the Tor Browser Bundle
(https://www.torproject.org/dist/torbrowser/tor-browser-2.2.37-1_en-US.exe)

When I try running the program it starts off as "Not responding" which never happened before then it leads to the error.

It also says Vidalia was unable to start the configured proxy server.

Things ive tried -

netsh winsock restart via cmd
Reinstalling Tor
Port forwarding (9050/9051)
Disabling/Enabling firewall
Changing ports for Tor
Restarting computer
Running as admin

Running Vista x86

http://puu.sh/MtFB
http://puu.sh/MtFM
http://puu.sh/MtGc

Log






Jul 28 12:45:26.299 [Notice] Tor v0.2.2.37 (git-fce6eb1c44e87bc2). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows Vista Service Pack 2 [workstation])
Jul 28 12:48:33.507 [Notice] Tor v0.2.2.37 (git-fce6eb1c44e87bc2). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows Vista Service Pack 2 [workstation])


This is a yellow warning in the logs


Jul 28 12:50:33.488 [Warning] Warning from libevent: evsig_init: socketpair: Connection refused [WSAECONNREFUSED ]


Jul 28 12:50:33.488 [Notice] Initialized libevent version 2.0.19-stable using method win32. Good.
Jul 28 12:50:33.488 [Notice] Opening Socks listener on 127.0.0.1:9050
Jul 28 12:50:33.488 [Notice] Opening Control listener on 127.0.0.1:9051
Jul 28 12:50:33.488 [Notice] Parsing GEOIP file .\Data\Tor\geoip.
Jul 28 12:50:37.205 [Notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Jul 28 12:50:37.310 [Notice] Bootstrapped 5%: Connecting to directory server.
Jul 28 12:50:37.310 [Notice] I learned some more directory information, but not enough to build a circuit: We have no network-status consensus.
Jul 28 12:50:37.421 [Notice] Bootstrapped 10%: Finishing handshake with directory server.
Jul 28 12:50:38.079 [Notice] Bootstrapped 15%: Establishing an encrypted directory connection.
Jul 28 12:50:38.513 [Notice] Bootstrapped 20%: Asking for networkstatus consensus.
Jul 28 12:50:38.841 [Notice] I learned some more directory information, but not enough to build a circuit: We have no network-status consensus.
Jul 28 12:50:39.611 [Notice] Bootstrapped 25%: Loading networkstatus consensus.
Jul 28 12:50:40.638 [Notice] Bootstrapped 45%: Asking for relay descriptors.
Jul 28 12:50:40.638 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 0/3031 usable descriptors.
Jul 28 12:50:41.080 [Notice] Bootstrapped 50%: Loading relay descriptors.
Jul 28 12:50:41.408 [Notice] Bootstrapped 53%: Loading relay descriptors.
Jul 28 12:50:41.408 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 96/3031 usable descriptors.
Jul 28 12:50:41.955 [Notice] Bootstrapped 57%: Loading relay descriptors.
Jul 28 12:50:41.955 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 192/3031 usable descriptors.
Jul 28 12:50:42.171 [Notice] Bootstrapped 61%: Loading relay descriptors.
Jul 28 12:50:42.171 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 288/3031 usable descriptors.
Jul 28 12:50:43.376 [Notice] Bootstrapped 64%: Loading relay descriptors.
Jul 28 12:50:43.376 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 384/3031 usable descriptors.
Jul 28 12:50:43.486 [Notice] Bootstrapped 68%: Loading relay descriptors.
Jul 28 12:50:43.487 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 480/3031 usable descriptors.
Jul 28 12:50:43.487 [Notice] Bootstrapped 72%: Loading relay descriptors.
Jul 28 12:50:43.487 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 576/3031 usable descriptors.
Jul 28 12:50:43.591 [Notice] Bootstrapped 75%: Loading relay descriptors.
Jul 28 12:50:43.591 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 672/3031 usable descriptors.
Jul 28 12:50:43.705 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 229/912 usable exit node descriptors.
Jul 28 12:50:43.705 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 258/912 usable exit node descriptors.
Jul 28 12:50:43.809 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 275/912 usable exit node descriptors.
Jul 28 12:50:43.922 [Notice] We now have enough directory information to build circuits.
Jul 28 12:50:43.922 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Jul 28 12:50:47.205 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Jul 28 12:50:49.170 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Jul 28 12:50:49.934 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Jul 28 12:50:49.934 [Notice] Bootstrapped 100%: Done.






If more information is needed I will gladly provide it.

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by arma

Milestone: TorBrowserBundle 2.3.x-stable
Priority: blockernormal
Resolution: duplicate
Status: newclosed

Duplicate of #6479. (Please reopen if I'm confused.)

Note: See TracTickets for help on using tickets.