Opened 7 years ago

Closed 7 years ago

#6492 closed defect (fixed)

Frequent Floating Point Exception/Div 0 Error in Tor Browser alpha

Reported by: mikeperry Owned by: mikeperry
Priority: Very High Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords: MikePerry201207
Cc: Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor:

Description

https://lists.torproject.org/pipermail/tor-qa/2012-July/000027.html reports a floating point exception in Tor Browser-alpha. tagnaq also reports frequent crashes.

I was able to reproduce this as well. It is due to the rewritten FF14 version of the pipeline randomization patch, where I was not as careful as I should have been when using the % operator..

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by tagnaq

Cc: tagnaq removed

I suppose #6487 is talking about the same issue.

comment:2 Changed 7 years ago by mikeperry

Actual Points: 1
Keywords: MikePerry201207 added; MikePerry201208 removed
Points: 1
Resolution: fixed
Status: newclosed

I just pushed an update to the pipeline patch that allows ip-check.info and news.bbc to work without crashing for me.

Note: See TracTickets for help on using tickets.