Opened 7 years ago

Closed 6 years ago

#6496 closed enhancement (not a bug)

Relocate HTTPS-E config file (from FF prefs.js)

Reported by: grarpamp Owned by: pde
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A default FF prefs.js is around 150 lines.
HTTPS-E blows that out with around 1500 more entries, which are expected to grow in number to some fraction of the worlds domains in time.
Admins probably don't want to carry optionally installed, and otherwise non-meta extension config like this, in their rolled out prefs.js.
And users probably don't want to mess their FF prefs on edit accident.
If adblock plus etc can relocate its config, so can HTTPS-E.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by pde

We would take a patch for this!

comment:2 Changed 7 years ago by pde

Priority: normalminor

comment:3 Changed 6 years ago by micahlee

Resolution: not a bug
Status: newclosed

This actually isn't an issue anymore, ever since #8776 we stopped storing all of the rulesets as prefs. Instead we only store changes to the default set of rulesets as prefs, so most users won't have any ruleset-related prefs until they manually disable a rule.

Note: See TracTickets for help on using tickets.