Opened 7 years ago

Closed 4 years ago

#6503 closed defect (fixed)

Single-word URL bar searching doesn't work

Reported by: mikeperry Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability-stoppoint-navigation, uxsprint2015, tbb-firefox-patch
Cc: arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm not sure what we did to disable it, but single-word url bar searching doesn't work in TBB unless you have a space in your url..

I'd rather have it behave like Firefox does, but just use Startpage instead of Google to avoid the captcha.

Child Tickets

Change History (15)

comment:1 Changed 7 years ago by mikeperry

See #5925 for some potentially related prefs. However, none of those actually worked in Tor Browser for me. Perhaps this bug is actually due to our SOCKS prefs being set?

comment:2 Changed 6 years ago by mikeperry

Keywords: tbb-usability added

comment:3 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:4 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Owner: changed from mikeperry to tbb-team

comment:5 Changed 5 years ago by saint

A possible solution might be to detect whether the purported address contains a dot. If it doesn't, process it as a search query.

Firefox has a feature to detect valid TLDs before deciding whether to process it as a domain name or a search query. It may be worth reviewing why this was removed for Tor Browser.

Last edited 5 years ago by saint (previous) (diff)

comment:6 Changed 5 years ago by gk

Cc: arthuredelstein added
Keywords: tbb-usability-stoppoint-navigation uxsprint2015 added; tbb-usability removed

#14636 is a duplicate.

comment:7 Changed 5 years ago by mcs

Testing with Tor Browser 4.0.3 on Mac OS, I confirmed that the Firefox's fallback to a keyword-based search does not work in Tor Browser. This shows up on the Browser Console:

Tor NOTICE: Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.

Interestingly, if I change the browser's proxy settings to not go through tor at all this feature works: a single word takes me to startpage search results. So maybe the "fallback to a search" feature does not work when a proxy is configured. Or at least not when tor is the proxy.

comment:9 Changed 5 years ago by dcf

By the way, cool hidden feature, you can do a single-word search in the location bar if you prefix the word with a question mark, like ?onions.

I learned this because in Firefox, you can type Ctrl-L to focus the location bar and Ctrl-K to focus the search box. In Chrome, because there's no search box, Ctrl-L puts you in the location bar, and Ctrl-K also puts you in the location bar but auto-inserts a ? at the beginning.

comment:10 Changed 4 years ago by dcf

At winter dev meeting 2015, fqueze said that something about single-word queries had changed in upstream Firefox. Something about, single-word queries were taking a long time because they were doing a DNS lookup first, so they changed how it works.

comment:11 in reply to:  10 Changed 4 years ago by gk

Replying to dcf:

At winter dev meeting 2015, fqueze said that something about single-word queries had changed in upstream Firefox. Something about, single-word queries were taking a long time because they were doing a DNS lookup first, so they changed how it works.

We talked about it and agreed that it was a different bug that got fixed. The issue in this ticket (tracked in bug 536955 upstream) is still not resolved yet.

comment:12 Changed 4 years ago by gk

Keywords: tbb-4.5-alpha added
Owner: changed from tbb-team to gk
Status: newassigned

Works with a vanilla ESR 31.5.3, interesting. Let's see if we get this sorted out last-minute for 4.5.

comment:13 in reply to:  12 Changed 4 years ago by gk

Status: assignedneeds_information

Replying to gk:

Works with a vanilla ESR 31.5.3, interesting. Let's see if we get this sorted out last-minute for 4.5.

But not if we are setting network.proxy.socks_remote_dns to true. In this case Firefox 33 is the first version to have this problem fixed. Some testing gives https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=99f694d1b50&tochange=35f3fa435d2c as the commit range. https://bugzilla.mozilla.org/show_bug.cgi?id=693808, which Florian pointed too, seems the likely candidate for the bugfix.

I have rebased that patch set to ESR 31 in my bug_6503. There are only minor conflicts which I resolved as a PoC without studying them further + the branch is totally untested. Given that do we want to try getting it into the next alpha (assuming I indeed hit the right bug :) )?

comment:14 Changed 4 years ago by gk

Keywords: tbb-4.5-alpha removed
Status: needs_informationassigned

Looking a bit deeper we'd need to pull in more than half a dozen patches (some of them not small) in order to fix that problem properly. I think that is too big to just drop it into 4.5 without having at least one alpha cycle. Dropping it off of the 4.5 radar. I think shipping this in alphas based on ESR 38 without the need for backporting any patches is good enough given that we are starting with preparations to switch to ESR 38.

comment:15 Changed 4 years ago by gk

Resolution: fixed
Status: assignedclosed

This is actually fixed in the alpha and in 5.0 which is due today.

Note: See TracTickets for help on using tickets.