Opened 7 years ago

Closed 6 years ago

#6566 closed defect (fixed)

broken "Transparent Torification (Requires custom transproxy or Tor router)"

Reported by: proper Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: proper Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

How to reproduce:

  1. Install Tor Browser tor-browser-gnu-linux-i686-2.2.37-2-dev-en-US.tar.gz
  2. Go to Tor Button options menu and choose "Transparent Torification (Requires custom transproxy or Tor router)"
  3. Press ok.

Result:

  1. Nothing happens.
  2. When closing the Tor Button options menu and reopening it, the setting will be stored but defunct.
  3. Why trying to visit any websites "The proxy server is refusing connections".
  4. In about:config all proxy related settings are wrong.

Expected result:

  1. Tor Button options dialog closes after pressing ok.
  2. Tor Browser uses no proxy settings at all. It behaves like a any ordinary non-torified application, such as wget, firefox without any proxy settings, etc.. Subsequently, if the user isn't using a TransProxy, he should use Tor Browser with its regular IP from its ISP. (Or when using TransProxy, the Tor IP.)

Child Tickets

Attachments (1)

0001-Fix-bug-6566.patch (887 bytes) - added by sukhbir 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by mikeperry

Priority: normalmajor

comment:2 Changed 7 years ago by riteguard

I seem to be experiencing this as well. Only difference is that im using windows(win7 pro x64) with tor-browser-2.2.39-5_en-US. When i change torbutton to use transparent torification and hit ok...the torbutton window becomes unresponsive for a min or two then it comes back to life...but if i rehit ok...it does the same thing. If i hit cancel and check the proxy settings in about:config i also see none of the settings where changed. Also once i hit cancel the torbutton icon changes to the onion with a red x on it...not sure if the torbutton settings are being corrupted or what.

comment:3 Changed 7 years ago by noflag

Also broken on the latest version of Ubuntu and Firefox

Changed 6 years ago by sukhbir

Attachment: 0001-Fix-bug-6566.patch added

comment:4 Changed 6 years ago by sukhbir

On checking the error console, I saw this error (which explains why nothing happens when this is set):

Error: ReferenceError: strings is not defined
Source File: chrome://torbutton/content/preferences.js
Line: 252

The attached patch should fix this problem.

comment:5 Changed 6 years ago by mikeperry

Keywords: MikePerry201303 added
Status: newneeds_review

comment:6 Changed 6 years ago by mikeperry

Keywords: MikePerry201304 added; MikePerry201303 removed

comment:7 Changed 6 years ago by mikeperry

#8632 is a dup of this.

comment:8 Changed 6 years ago by tagnaq

Thank you for the patch, works for me after applying.

The only remaining bug: The onion remains green (and doesn't become grey with the red X) when enabling transparent torification (without actually having any TransPort).

comment:9 Changed 6 years ago by proper

I don't think that's a bug.

It is my understanding, that the grey onion with the red X is only a relict from the toggle feature, which meant TorButton is currently disabled. So not having a grey onion with the red X is actually a good thing?

comment:10 Changed 6 years ago by mikeperry

Keywords: MikePerry201304 removed
Resolution: fixed
Status: needs_reviewclosed

This is merged and is in Torbutton 1.5.2. I like using the Torbutton icon to indicate Tor failure, but I agree that is a separate issue. We can consider it when we make our homepage local (#7494).

Note: See TracTickets for help on using tickets.