Opened 7 years ago

Closed 5 years ago

Last modified 21 months ago

#6576 closed defect (fixed)

Page loading indicator disappears during redirect in TBB 2.2.37-2

Reported by: rransom Owned by: pde
Priority: Immediate Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: mikeperry, pde, StrangeCharm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I followed a link from the GMail page for https://lists.torproject.org/pipermail/tor-dev/2012-August/003895.html to a Tor Trac ticket. This sent me through a Google redirect page (with URL “http://www.google.com/url?q=https%3A%2F%2Ftrac.torproject.org%2Fprojects%2Ftor%2Fticket%2F6374&sa=D&sntz=1&usg=(cryptographic authenticator removed)”). The page-loading animation in the Firefox tab disappeared after the Google redirect page loaded, but before trac.tpo loaded. The Trac page continued to load, and eventually replaced the redirect page.

(Someone else will have to set up a redirect page to test this; the Google one refuses to perform the redirect silently with the usg= URL parameter removed, and I suspect (and hope) that the authenticator tag they gave me won't work for anyone else.)

Child Tickets

Attachments (1)

url.html (412 bytes) - added by rransom 7 years ago.
Google redirect page

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by rransom

Attachment: url.html added

Google redirect page

comment:1 Changed 7 years ago by rransom

I've attached the Google redirect page to the ticket; it uses a JavaScript redirect.

I filed this as a new ticket against HTTPS Everywhere because (a) this is probably related to a broken attempt to fix #5477, and (b) I do not remember the page-loading animation disappearing during the redirect in #5477, so this is a separate (but related) bug.

comment:2 Changed 7 years ago by mikeperry

FYI: the #5477 fix is not active in your TBB version yet. It won't take effect until 3.0dev6 of HTTPS-Everywhere is shipped. It also won't apply to TBB 2.2.x, only 2.3.x has the requisite Firefox patch for now.

However, I am curious if this issue will still happen with that fix. The new API's internal redirect machinery should be a lot more clean wrt notifications and observers, as it is the same codepath as HSTS uses and I believe great care was taken to preserve all the notifications in the right order with HSTS.

comment:3 Changed 7 years ago by pde

Robert, is there a chance you could to reproduce this with a patched Firefox and a build-from-git of HTTPS Everywhere? (If you need a handy version of the latter, https://www.eff.org/files/https-everywhere-experimental.xpi; for the former, you could apply https://bugzilla.mozilla.org/attachment.cgi?id=645172 and build Firefox, or ask mike or me for a binary)

It would be great to know if there are any inadequacies in our Firefox patch /before/ jduell at Mozilla reviews it, which I hope will happen at an unpredictable time in the next work week or.

comment:4 Changed 7 years ago by pde

s/could to/could try to/

comment:5 Changed 7 years ago by mikeperry

I am unable to reproduce this in TBB 2.2.x with a random JS redirect demo: http://www.tizag.com/javascriptT/examples/timedelay.php

The good news is that TBB 2.3.x-alpha now has the redirectTo API, and you can click "Find Updates" for HTTPS-Everywhere to get updated to 3.0dev6 which uses the API, so we can now test the actual gmail case.

comment:6 Changed 6 years ago by micahlee

I just tried reproducing this in TBB 2.3.25-12, following a link from Gmail, and couldn't. I don't believe this is an issue anymore. Any objections to me closing this ticket?

comment:7 Changed 5 years ago by jsha

Resolution: fixed
Status: newclosed

Sounds good, closing.

comment:8 Changed 21 months ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.