Opened 5 years ago

Last modified 10 days ago

#6592 accepted defect

HTTPS Everywhere Causes WordPress.com Zemanta Media Gallery To Not Work

Reported by: goodjohnjr Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,

Every version of HTTPS Everywhere that I have tested has caused a problem with at least one of the common websites that I visit, so I finally am reporting one of these problems.

When using WordPress.com with Zemanta enable, the Media Gallery/Recommended Images show up, but the hover feature that allow you to preview images does not work and clicking images to add them to your post does not work when HTTPS Everywhere is installed.

Here is an example of what Zemanta looks like on WordPress.com:

http://en.support.files.wordpress.com/2010/08/zemanta_before.png

I am using HTTPS Everywhere in the latest Firefox and have had this problem in other versions of Firefox, and with various versions of HTTPS Everywhere.

I think this problem happens even if HTTPS Everywhere is disabled, but once uninstalled the problem stops, but I could be wrong.

Thank you,
-John Jr :)

Child Tickets

Change History (9)

comment:1 Changed 5 years ago by goodjohnjr

I forgot to mention that I tried disabling the WordPress rule, but that did not work; and I tried to find if there was a rule for Zemanta, but I did not see one.

comment:2 Changed 5 years ago by goodjohnjr

After some experimenting, I found that disabling the Wikipedia and Flickr rules allows Wikipedia & Flickr images to work, so now I can get hover/mouse-over previews of images & I can add images from those two services using Zemanta in WordPress.com. :)

comment:3 Changed 5 years ago by pde

Parent ID: #3190
Status: newaccepted

Hi!

This is a browser extension incompatibility bug, #3190. We are still waiting for Firefox to accept our patch to fix it...

comment:4 in reply to:  3 Changed 5 years ago by goodjohnjr

Replying to pde:

Hi!

This is a browser extension incompatibility bug, #3190. We are still waiting for Firefox to accept our patch to fix it...

Hello,

Thank you, I hope that the Firefox Team accepts that patch soon. :)

comment:5 Changed 5 years ago by pde

Hi goodjohnjr, we believe that a fix for this bug should hopefully now be in the mozilla central codebase. Is there any chance you could test this with today's Firefox 21 nightly build?

comment:6 in reply to:  5 Changed 5 years ago by goodjohnjr

Replying to pde:

Hi goodjohnjr, we believe that a fix for this bug should hopefully now be in the mozilla central codebase. Is there any chance you could test this with today's Firefox 21 nightly build?

Hello,

Thank you for the update, I installed the nightly build but the problem is still there, then I updated the nightly build to 21.0a1 (2013-01-30); but the problem is still there.

The media gallery images show up (as they did before), but when you hover the mouse cursor over the images the previews of the images & image information (letting you know if it is on/from Wikimedia, Flickr, et cetera) & the link for the images do not show up & if you click on an image to add it to your post nothing happens.

So unfortunately this problem is still there after all this time still. :(

comment:7 Changed 5 years ago by pde

Parent ID: #3190

Okay, I'm detaching this bug from #3190 then. We will need to do further investigation to determine whether this is a a ruleset bug, a combination of #3190 and a ruleset bug, or something else altogether.

comment:8 in reply to:  7 Changed 5 years ago by goodjohnjr

Replying to pde:

Okay, I'm detaching this bug from #3190 then. We will need to do further investigation to determine whether this is a a ruleset bug, a combination of #3190 and a ruleset bug, or something else altogether.

Okay, thank you very much, please do let me know if you need more information about the problem (screenshots, program/system information, et cetera). :)

comment:9 Changed 10 days ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.