Opened 7 years ago

Closed 7 years ago

#6594 closed defect (fixed)

Vidalia/Tor in TBB latest make UMTS modem disconnect from Internet

Reported by: Eugene Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: chiiph, Shondoit, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Computer: NEC with 2 GiHz processor and 1 GiB RAM; Windows XP SP3 32-bit fully patched; HUAWEI USB Stick (UMTS modem) E1550; latest TBB; on start of Tor Browser, Vidalia proceeds to "downloading relay information" then stops. HUAWEI "Mobile Partner" software 11.302.09.03.382 malfunctions (i.e., suddenly does not "recognize the device" anymore and the connection to the Internet is abruptly cut).

In Windows Error Log:

Application Error (1)
Application Failure vidalia.exe 0.2.20.0 in qtcore4.dll 4.8.1.0 at offset 00249022..

Application Error (2)
Bucket: -1205820069..

DrWatson
Application "C:\Documents and Settings\[NAME]\My Documents\Downloads\Tor Browser\App\vidalia.exe" caused a program error. Date and time of error: [...] Exception: c0000005 at address 6E309022 (QtCore4!ZN16QEventTransition16staticMetaObjectE)

Child Tickets

Change History (6)

comment:1 Changed 7 years ago by rransom

Cc: chiiph Shondoit added
Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:2 Changed 7 years ago by rransom

Cc: erinn added
Component: Tor bundles/installationVidalia
Owner: changed from erinn to chiiph

Er, this looks like a Vidalia bug (crashing because Tor changed bootstrap state). (Also, I doubt that HUAWEI ‘Mobile Partner’ is really malfunctioning.)

comment:3 Changed 7 years ago by Eugene

Dear rransom, if "malfunction" is the wrong word to describe the unwanted behavior of the Mobile Partner software, which word should I have used instead?

Please let me know if I can collect any additional data that would help you to pinpoint the problem.

comment:4 Changed 7 years ago by Eugene

Summary: Crash in TBB latestVidalia/Tor in TBB latest make UMTS modem disconnect from Internet

Changed title to better reflect problem.

comment:5 Changed 7 years ago by Eugene

No improvement from updating to Tor 0.2.2.39

Vidalia gives "Loading relay information failed (no route to host)" and a bunch of identical error messages:

"Sep 17 01:02:25.484 [Warning] Problem bootstrapping. Stuck at 50%: Loading relay descriptors. (No route to host [WSAEHOSTUNREACH ]; NOROUTE; count 153; recommendation warn)"

comment:6 Changed 7 years ago by Eugene

Resolution: fixed
Status: newclosed

I have some good news to report. The latest alpha Tor Browser Bundle now works trouble-free with the UMTS modem. However, I suspect that the improvement may not be due to Tor software but to one of the updates from Microsoft that arrived in the interim. The reason I think so is that I was getting intermittent disconnects after an hour or so of browsing normally with Firefox (without Tor). These disconnects are no longer occurring.

Resolving as "fixed"...

Note: See TracTickets for help on using tickets.