Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6595 closed defect (not a bug)

different streams sometimes end up with same exit node IP

Reported by: proper Owned by:
Priority: High Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client
Cc: proper Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Related to #6342.

It happens that different SocksPorts end up with the very same exit IP, thus stream isolation is practically ignored.

Seldom, but happens.

If you are interested I can provide shell scripts for checking different Socks- or TransPorts reporting if they get the same exit IP.

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by rransom

Status: newneeds_information

Are the streams on the same circuit, or on different circuits?

comment:2 Changed 7 years ago by arma

See my comment on #6342 -- my guess is you're misunderstanding what stream isolation is supposed to do.

comment:3 in reply to:  1 Changed 7 years ago by proper

Resolution: not a bug
Status: needs_informationclosed

Replying to rransom:

Are the streams on the same circuit, or on different circuits?

Not checked.

Replying to arma:

See my comment on #6342 -- my guess is you're misunderstanding what stream isolation is supposed to do.

Yes.

comment:4 Changed 7 years ago by nickm

Keywords: tor-client added

comment:5 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.