Opened 7 years ago

Closed 7 years ago

#6610 closed task (fixed)

Please create compass.git and compass.torproject.org

Reported by: karsten Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: gsathya Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Compass is a script and website to extract relay statistics. It downloads and caches Onionoo's relay data and can filter and aggregate relay information. It's currently maintained in metrics-tasks.git.

Please create an official Git repo compass.git with description "script and website to extract relay statistics" and grant push access to gsathya and me. Also, please create a public user/karsten/compass.git repository for me. (Not sure if Sathya wants a public repo, too.)

Further, please add a directory /srv/compass.torproject.org/ to vescum or some other web server that can host the website as compass.torproject.org, and please add a DNS entry for this sub domain.

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by Sebastian

Please don't file git repository creation requests in trac as "Tor Sysadmin Team" things. I only saw this accidentally, git repository maintenance is not a Sysadmin task. repo created.

comment:2 in reply to:  1 Changed 7 years ago by karsten

Replying to Sebastian:

Please don't file git repository creation requests in trac as "Tor Sysadmin Team" things. I only saw this accidentally, git repository maintenance is not a Sysadmin task. repo created.

What's the preferred communication channel for Git repository maintenance requests? Don't say IRC. ;)

Thanks for creating the repositories! I just confirmed they work fine.

comment:3 Changed 7 years ago by Sebastian

I don't know what the preferred place is for the collective of git repo maintainers, but for me it would indeed be irc. This is OT here, tho.

comment:4 in reply to:  description Changed 7 years ago by karsten

Replying to karsten:

Further, please add a directory /srv/compass.torproject.org/ to vescum or some other web server that can host the website as compass.torproject.org, and please add a DNS entry for this sub domain.

The Git repo now contains the code that shall be deployed on vescum or one of the other web servers.

weasel, can we get a directory /srv/compass.torproject.org/ (on vescum?), a DNS entry, and an Apache site configuration (see README.md for details)?

The Git repo will be cloned into /srv/compass.torproject.org/compass/.

We'll probably want to have /srv/compass.torproject.org/ group-writable for a new group (or role account) called compass, because we want to install an hourly cronjob that downloads the file details.json to the compass directory.

Thanks!

comment:5 Changed 7 years ago by karsten

Resolution: fixed
Status: newclosed

weasel just set this up on tanguticum. Closing. Thanks!

Note: See TracTickets for help on using tickets.