Opened 7 years ago

Closed 5 years ago

#6645 closed defect (worksforme)

[CHROME] weird charset changes on pages with no HTTPS rewrites

Reported by: hanno Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: aaronsw, mikeperry, dtauerbach Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I recently discovered that when I opened a httpauth page in chromium, I get the wrong charset. However, after a first reload I get the correct one.

Further investigation showed that
a) the httpauth login page had a different charset than the page behind and on first load the charset of the httpauth was used
b) this only happens when the https everywhere extension is enabled
Therefore I assume it's a bug in the extension. Bug reported at chromium is here:
https://code.google.com/p/chromium/issues/detail?id=142929

And a sample page to test:
http://test.hboeck.de/
With login guest, password guest
(no https involved at all, so I don't understand why https everywhere causes a change, but it definitely does)

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by pde

Hi Hanno,

Do you think this might be another instance of #6197? That's an annoying bug in the Chrome version of HTTPS Everywhere that's becaused by an underlying jsuri bug. If so, perhaps it's time to wade in and fix jsuri...

comment:2 Changed 7 years ago by pde

Cc: aaronsw mikeperry added

Hmmm, in retrospect I don't think this could have been jsuri-related. In fact, it's really weird. CC'ing Aaron and Mike, in case either of them have any ideas.

comment:3 Changed 7 years ago by pde

Cc: dtauerbach added
Summary: https everywhere on chromium causes strange charset bug[CHROME] weird charset changes on pages with no HTTPS rewrites

comment:4 Changed 5 years ago by jsha

Resolution: worksforme
Status: newclosed

Can't reproduce. When I try submitting the provided credentials on the test page, it just goes back to the test page.

Note: See TracTickets for help on using tickets.