Opened 7 years ago

Closed 6 years ago

#6658 closed defect (fixed)

Please make an ldap account for vmon

Reported by: vmon Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: weasel, arma, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by vmon)

vmon needs a new LDAP account for torproject.org. because, he'd like also to get the blockage update from Runa and look into them (following our discussion about censorship in Florence) and Runa asked for an LDAP account.

First name: Veggie
Last name: Monster
Desired uid: vmon
Forwarding address: vmonmoonshine _a_t_g_m_a_i_l
PGP fingerprint(encrypt): 25FE 1E38 CFE2 B018 D915 D5D4 2037 F1B1 FB9E 896D

Capabilities: sign certify
Fingerprint: 8EDB1FD7C431791768C1C5BB34F31DCDDF3E7BB8

Capabilities: encrypt
Fingerprint: 25FE1E38CFE2B018D915D5D42037F1B1FB9E896D

Child Tickets

Change History (12)

comment:1 Changed 7 years ago by runa

All files related to blocking diagnostics are on lemmonii, so vmon needs an LDAP account to access it. I asked if he had one, he didn't. Nick said he'd approve this request.

comment:2 Changed 7 years ago by nickm

I approve. Weasel is going to want more evidence than this that what you posted is your real GPG key.

comment:3 Changed 7 years ago by weasel

Status: newneeds_information

nobody has signed this key. somebody needs to do some verification here.

comment:4 Changed 7 years ago by arma

Right. Maybe somebody can find vmon on irc and do some "is this trac ticket you" checking?

comment:5 in reply to:  4 ; Changed 7 years ago by rransom

Replying to arma:

Right. Maybe somebody can find vmon on irc and do some "is this trac ticket you" checking?

‘vmon’ is not registered with NickServ, so talking to someone who currently claims to be vmon is not going to help.

comment:6 in reply to:  5 Changed 7 years ago by vmon

Description: modified (diff)
Type: taskdefect

Replying to rransom:

Right. Maybe somebody can find vmon on irc and do some "is this trac ticket you" checking?

‘vmon’ is not registered with NickServ, so talking to someone who currently claims to be vmon is not going to help.

I talk to rransom and registered vmon on NickServ.

As a way to authenticate me/key we (me and rransom) agreed that I'll commit a file containing the finger print on zackw's stegotorus repo (because zackw gave me access to that repo in Italy in person). But apparently I don't have access to that repo any more, for some reason.

I'll ask somebody (rransom/arma) about other way of being authenticated.

comment:7 Changed 7 years ago by vmon

Description: modified (diff)

Apparently, the problem was that I blocked zack by mistake and hence lost access to his repo. The problem is solved now. I pushed my public key and fingure print here:

https://github.com/zackw/stegotorus/tree/this-is-vmon

in these files:

https://github.com/zackw/stegotorus/blob/this-is-vmon/vmon-pgp-fingureprint.xt
https://github.com/zackw/stegotorus/blob/this-is-vmon/vmon-pgp-public-key.asc

comment:8 Changed 6 years ago by arma

Looks good to me. Weasel, let's move forward on this please. Do you need anything more from me?

(I hereby say that I have authenticated that this key is vmon's key.)

comment:9 Changed 6 years ago by weasel

Roger, a signed blurb as documented on https://help.torproject.org/tsa/doc/accounts/ (step 1) would be helpful.

Also note that the key mentioned in this ticket is not yet available from keyservers.

comment:10 in reply to:  9 Changed 6 years ago by vmon

Replying to weasel:

Roger, a signed blurb as documented on https://help.torproject.org/tsa/doc/accounts/ (step 1) would be helpful.

Also note that the key mentioned in this ticket is not yet available from keyservers.

I'm not sure who is sponsoring my ldap account to ask to sign my key.I have been in contact with Andrew mostly lately. Also Zack was my mentor, though it is not easy to get a hold of him. Any suggestion?

The key is indeed on mit server since may 2012:

gpg --keyserver pgpkeys.mit.edu --recv-key DF3E7BB8

comment:11 Changed 6 years ago by arma

Status: needs_informationnew
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256


vmon maintains a stegotorus branch that we'd like to maintain in Tor's
git rather than wherever he keeps it now.


First name: Veggie
Last name: Monster
Desired uid: vmon
Forwarding address: vmonmoonshine _a_t_g_m_a_i_l

$ gpg --fingerprint 8EDB1FD7C431791768C1C5BB34F31DCDDF3E7BB8
pub   2048D/DF3E7BB8 2012-05-18
      Key fingerprint = 8EDB 1FD7 C431 7917 68C1  C5BB 34F3 1DCD DF3E 7BB8
uid                  Veggie Monster (full pipeline freedom) <vmon@riseup.net>
uid                  Veggie Monster (Love is me not eating you.) <vmonmoonshine@gmail.com>
sub   4096g/FB9E896D 2012-05-18

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJSEpqXAAoJEMIYUlgZ94RRkfgP/2J/4mM1t8NuYc0T9rbdc6+2
HNCO748xMmhgfX7KGA/p57qEhZG5DLlmkU7EmodMP1QUCIkUqKvc8r+5K4QSfFF4
5YHNvApUKxYu1emMPeEkuo4dHkR4PLud0mU5o+vt2iLNDAytGz1lB0kYTULUl6V0
Yv5rfSBwWLZhNbfL4mWFPndPytMXdCCY2aa5DMcE2bTA4KU6T1cq3phqUj1o+ddA
FlD+05IKe6UHIdFrK1J29IYc85nUnoLtAfLWD5wG+RF5bVw8rRY9S0EMbJBfCAGb
adcpyhtT5VaYrZCgIvRJKdnx+QqdxVp3b7oQSqrMmK7wdkNitg81JcYZ29RNX4lq
d6d9Drg0n020iZtRwvsvlaqQHmUUJJ8B3kp8bylUfod6b/N3TRNuK6stNIw1uwdy
q0FYHYC4IxSzKRa27dEbpEe785RQLv3dLxtlT0TnfUgkhu/zA42KRh2tW4D4YiHn
ebCTRJPwIM6DGek7e+TNRseqo12vCThUl+njEr4SR21RUyDh4sg0OHZ19LjfptoW
qob5xc0TlHdSLyjz7MrRUnQnUtXDrpZREO/9ie7nEBm95zyyjjarLbc9fr4Tqh3u
BL9UBIS9g9J4j1xonsqnnUMfmo3TND7uiJR8NU7E4B/c3WrxR04dMH1H0K/ElKZR
sb50YZdSxws8Lc1+HOVv
=rC9o
-----END PGP SIGNATURE-----

comment:12 Changed 6 years ago by weasel

Resolution: fixed
Status: newclosed

Final information collected:

Veggie Monster <vmon@…>:

Assigned UID: 2054 GID: 2054
Email forwarded to: vmonmoonshine@…
GECOS Field: "Veggie Monster"
Login Shell: /bin/bash
Key Fingerprint: 8EDB1FD7C431791768C1C5BB34F31DCDDF3E7BB8

Continue [No/yes]? yes
Updating LDAP directory..
Sending Welcome Email

Note: See TracTickets for help on using tickets.