Opened 6 years ago

Closed 5 years ago

#6661 closed defect (fixed)

Unable to open Google specific links in TBB

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version: Tor: 0.2.3.20-rc
Severity: Keywords: tbb-usability-website
Cc: g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Similar to #6191 I'm unable to create a google docs spreadsheet.

Steps to reproduce:

  1. login
  2. click on "create"
  3. select "spreadsheet" in the drop down menu that appears
  4. a new tab opens (white page no content)

Child Tickets

Change History (12)

comment:1 Changed 6 years ago by cypherpunks

Component: Tor bundles/installationFirefox Patch Issues
Owner: changed from erinn to mikeperry

Changed the component to 'Firefox Patch Issues' (like in #6191).

I'm using tor-browser-gnu-linux-x86_64-2.3.20-alpha-1-dev-en-US.tar.gz

comment:2 Changed 6 years ago by mikeperry

Keywords: tbb-usability added

comment:3 Changed 6 years ago by gk

Cc: g.koppen@… added

comment:4 Changed 6 years ago by mikeperry

This is unlikely to get very much attention, unfortunately. One thing that will certainly make it go quicker is if someone can narrow down what is causing this on our side.

Does turning off any of the Torbutton privacy preferences stop it from happening?

Does it still happen with Torbutton in a Vanilla Firefox?

Is it because we set one of these prefs, by any chance:
https://gitweb.torproject.org/torbrowser.git/blob/HEAD:/build-scripts/config/prefs.js

comment:5 Changed 6 years ago by mikeperry

Keywords: tbb-usability-website added; tbb-usability removed

comment:6 Changed 6 years ago by runa

Summary: unable to create a google docs spreadsheet document with TBBUnable to open Google specific links in TBB

The issue seems to be present for all Google specific links; creating any type of Google Docs document, opening any Gmail specific link, and so on.

comment:7 Changed 6 years ago by runa

I can add that this also happens when you try to follow a link in an email; clicking on a link that says https://www.torproject.org/ results in a new tab, blank page, and https://mail.google.com/mail/?shva=1 in the address bar.

comment:8 in reply to:  4 Changed 6 years ago by runa

Replying to mikeperry:

Does turning off any of the Torbutton privacy preferences stop it from happening?

Turning off "Isolate dynamic content to Tor state (crucial)" fixes the issue.

comment:9 Changed 6 years ago by mikeperry

Thanks Runa! If that pref is the cause for all of the Google link failures, then simply removing that code should do the trick. There are other reasons to remove it, too (#5279).

However, we'll probably going to want to ponder the side effects of that removal. I know it might change a bit about how New Identity works in terms of the tab tags (which are only defense in depth anyways), for example...

comment:10 in reply to:  9 ; Changed 6 years ago by runa

Replying to mikeperry:

Thanks Runa! If that pref is the cause for all of the Google link failures, then simply removing that code should do the trick. There are other reasons to remove it, too (#5279).

Where in the codebase should I look?

However, we'll probably going to want to ponder the side effects of that removal. I know it might change a bit about how New Identity works in terms of the tab tags (which are only defense in depth anyways), for example...

Any suggestions on where to start to figure out how this will change New Identity and, possibly, other things?

comment:11 in reply to:  10 Changed 6 years ago by mikeperry

Replying to runa:

Replying to mikeperry:

Thanks Runa! If that pref is the cause for all of the Google link failures, then simply removing that code should do the trick. There are other reasons to remove it, too (#5279).

Where in the codebase should I look?

The observer for this is the nsIContentPolicy:
https://gitweb.torproject.org/torbutton.git/blob/HEAD:/src/components/cssblocker.js

However, we'll probably going to want to ponder the side effects of that removal. I know it might change a bit about how New Identity works in terms of the tab tags (which are only defense in depth anyways), for example...

Any suggestions on where to start to figure out how this will change New Identity and, possibly, other things?

Unfortunately, the main reason I want to tear this old code out is because it's rather convoluted and full of voodoo from toggle mode. You can get some of the background in #1506 and the associated comments...

However, I think for the most part the content policy should be fairly isolated. I think the New Identity parts won't break without it, they'll just be setting some window tags they don't need to.

comment:12 Changed 5 years ago by mikeperry

Resolution: fixed
Status: newclosed

We have removed this code. This should be fixed. Reopen if not.

Note: See TracTickets for help on using tickets.