Opened 7 years ago

Closed 2 years ago

#6741 closed defect (user disappeared)

Vidalia not-responding after minute of working

Reported by: HavingError12 Owned by: chiiph
Priority: Very High Milestone:
Component: Archived/Vidalia Version: Vidalia: 0.2.20
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm having strange problems with Vidalia in Windows.
Before the main problem there were errors while connecting to TOR like client only. When I pushed Start Tor Vidalia started Tor but displayed this process incorrectly. When TOR was already connected and check.torproject.org worked fine Vidalia still displayed yellow "connecting" onion instead of green one, it became green by the time, long after TOR had begun really working. Network map displayed node list, but not my circuits. Message log was also not fine. After displaying message "bootstapped 100%" there were messages like "we have 0/1800 descriptors", "we have 100/1800 descriptors" and so on. When I interrupted connecting by pushing "Stop Tor" Vidalia displayed message box

"Vidalia was unable to register for some events. Many of Vidalia's features may be unavailable.

Control socket is not connected."

These strange things began some weeks ago and happened with Vidalia bundle version 0.2.2.35-0.2.15 and after update to 0.2.2.37-0.2.19.
Main, much stranger problem begun when I tried running a non-exit TOR relay. I upgraded Vidalia bundle to version 0.2.2.38-0.2.20. At first it succeded and no problems happened but next time troubles begun. Vidalia started TOR and relay but in a minute or so Vidalia windows became completely white (blank) and not-responding, Vidalia's green onion in taskbar ignored right mouse clicks, while TOR itself continued working and check.torproject.org worked fine. It continued happening when I switched to client only. Then I tried installing older Vidalia bundle versions (0.2.2.35-0.2.15 and 0.2.2.37-0.2.19) all the same. Now I'm writing using TOR from other Windows machine and all works fine.
I suspect attack though political regime in my country isn't supposed to be so oppressive as in China.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by sysrqb

Status: newneeds_information

Hi HavingError12,

What version of Windows do you use? Also, does this happen every time you start Tor using Vidalia or does it work sometimes but not other times?

For clarity, can you also confirm the following:

  • Your second problem did not exist when you first used version 0.2.2.35-0.2.15.
  • After you installed version 0.2.2.38-0.2.20 Vidalia occasionally became unresponsive.
  • You then downgraded back to version 0.2.2.35-0.2.15 and found Vidalia continued to be unstable

Is this correct?

comment:2 Changed 2 years ago by cypherpunks

Keywords: Vidalia 0.2.15 0.2.19 0.2.20 Tor 0.2.2.35 0.2.2.37 0.2.2.38 Windows removed
Resolution: user disappeared
Severity: Normal
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.