Opened 7 years ago

Closed 5 years ago

#6745 closed defect (fixed)

TBB Vidalia fails to launch browser on Kubuntu 12.04 live usb.

Reported by: fran Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.3.25
Severity: Keywords: needs-triage
Cc: g.koppen@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

hi,
Running the 2.2.38-2 build of the Tor Browser Bundle on a Kubuntu 12.04 live usb and it gave the following problems.
Vidalia starts fine and connects to the network. The browser doesn't start with the error :

(firefox:stderr): XPCOMGlueLoad error for file /tmp/tor-browser_en-US/App/Firefox/libxpcom.so:
(firefox:stderr): libxul.so: cannot open shared object file: No such file or directory

I found the libxul.so in the App/Firefox directory.
However, adding "./App/Firefox" to the LD_LIBRARY_PATH env variable resulted in the following error:

(firefox:stderr): XPCOMGlueLoad error for file /tmp/tor-browser_en-US/App/Firefox/libxpcom.so:
(firefox:stderr): libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

ldd on the offending libxpcom shows :

libgtk-x11-2.0.so.0 => not found
libgdk-x11-2.0.so.0 => not found

Manually copying those files from another system into the local folders gets everything to work.
I noticed this first with the ver 2.2.38-1. I haven't check with any version prior to that.
I've been able to use 2.2.38-1 of the browser bundle with an installed version of Kubuntu 11.10.
This is the first time I've tried to use a version of the browser bundle with a Live USB.

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by gk

Cc: g.koppen@… added

comment:2 Changed 7 years ago by rransom

TBB-Firefox requires GTK 2, and does not include it because (a) it's huge, and (b) almost every distribution includes it. Except apparently Kubuntu.

The workaround is to install GTK (the Ubuntu package name is (currently) libgtk2.0-0). I doubt that this will be ‘fixed’.

comment:3 Changed 7 years ago by arma

A suitable fix could be for TBB to notice when this library isn't available, and tell you what's missing.

As rransom says though, this is one where we're going to need a volunteer to step up and do it.

comment:4 Changed 7 years ago by concern

Priority: normalmajor
Summary: TBB Vidalia fails to launch browser on Kubuntu 12.04 live usb.TBB Vidalia fails to launch browser on Ubuntu 12.04
Version: Tor: 0.2.2.38Tor: 0.2.3.25

Reproduced on a standard Ubuntu 12.04 LTS install. Tried tor-browser-gnu-linux-i686-2.3.25-1-dev-en-US and tor-browser-gnu-linux-i686-2.3.25-2-dev-en-US , problem exists in both. Error text is the same.

Package libgtk2.0-0 *is* installed.

Logged in as Guest - unable to test with standard user. TBB should operate fine as a Guest, by design, no?

This is likely affecting many users.

comment:5 in reply to:  4 Changed 7 years ago by rransom

Priority: majornormal
Summary: TBB Vidalia fails to launch browser on Ubuntu 12.04TBB Vidalia fails to launch browser on Kubuntu 12.04 live usb.

Replying to concern:

Reproduced on a standard Ubuntu 12.04 LTS install. Tried tor-browser-gnu-linux-i686-2.3.25-1-dev-en-US and tor-browser-gnu-linux-i686-2.3.25-2-dev-en-US , problem exists in both. Error text is the same.

Package libgtk2.0-0 *is* installed.

You are using the 32-bit TBB on a 64-bit OS, and libgtk2.0-0:i386 is not installed.

Logged in as Guest - unable to test with standard user. TBB should operate fine as a Guest, by design, no?

This is likely affecting many users.

Maybe (I tried the wrong TBB a few times back when I used Tor), but I think you're the first to have vandalized an unrelated Trac ticket over an architecture mismatch.

comment:6 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:7 Changed 5 years ago by erinn

Resolution: fixed
Status: newclosed

I'm closing this since we no longer ship Vidalia in TBB.

Note: See TracTickets for help on using tickets.