Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6770 closed defect (fixed)

Default value for AuthDirPublishIPv6 not honoured

Reported by: ln5 Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: ipv6 tor-auth
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

AuthDirPublishIPv6 is AUTOBOOL.
AUTOBOOL defaults to -1.
We check AuthDirPublishIPv6 like this

    options->AuthDirHasIPv6Connectivity == 0

in two places where we want to test whether it's "unset" or not. This
test will fail for AuthDirPublishIPv6 being -1.

After an interesting discussion with Roger on IRC, I suggest we make
this option BOOL.

The motivation is that we should have AUTOBOOL options only for things
decided from information from the consensus or the operating system
we're running on. Once we have code for autodetecting IPv6 support
from the OS we can turn it back into an AUTOBOOL again.

Child Tickets

Change History (11)

comment:1 Changed 7 years ago by ln5

Status: newneeds_review

Fix in branch bug6770 of my public repo.

comment:2 Changed 7 years ago by arma

looks plausible to me.

in your git commit message, you might mention the bug number, and your reasoning for switching it. otherwise the logic will be lost.

comment:3 Changed 7 years ago by arma

also mentioning "bug not in any released version of tor" in the git commit message will make people not pester you about a changes file.

comment:4 Changed 7 years ago by ln5

Right. Fixed in branch bug6770_2.

comment:5 Changed 7 years ago by ln5

Branch bug6770_3 even fixes the man page!

comment:6 Changed 7 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Merged #6771 , which had an independent fix.

comment:7 Changed 7 years ago by nickm

Resolution: fixed
Status: closedreopened

Reopening, because linus says the underlying problem of having an autobool here isn't fixed by #6770. This time I should actually look harder at the ticket.

comment:8 in reply to:  7 Changed 7 years ago by ln5

Replying to nickm:

Reopening, because linus says the underlying problem of having an autobool here isn't fixed by #6770. This time I should actually look harder at the ticket.

This is #6770.
Making a BOOL of the AUTOBOOL isn't fixed by #6771.
That is not a bug in itself but something Roger suggested.
#6771 fixes the bug but keeps the option AUTOBOOL.

comment:9 Changed 7 years ago by nickm

Resolution: fixed
Status: reopenedclosed

Merged bug6770_3

comment:10 Changed 7 years ago by nickm

Keywords: tor-auth added

comment:11 Changed 7 years ago by nickm

Component: Tor Directory AuthorityTor
Note: See TracTickets for help on using tickets.