Opened 7 years ago

Closed 2 years ago

#6775 closed defect (worksforme)

Bug: circuit_send_next_onion_skin

Reported by: hifferymchumphrey Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.3.22-rc
Severity: Normal Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Sep 05 16:44:36.175 [Notice] All routers are down or won't exit -- choosing a doomed exit at random.
Sep 05 16:44:36.301 [Notice] All routers are down or won't exit -- choosing a doomed exit at random.
Sep 05 16:44:37.211 [Notice] All routers are down or won't exit -- choosing a doomed exit at random.
Sep 05 16:44:37.983 [Notice] All routers are down or won't exit -- choosing a doomed exit at random.
Sep 05 16:44:37.986 [Notice] All routers are down or won't exit -- choosing a doomed exit at random.
Sep 05 16:44:38.155 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:587. Giving up.
Sep 05 16:44:41.011 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (7/6) for guard fejkse
Sep 05 16:44:41.994 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (8/6) for guard fejkse
Sep 05 16:44:42.435 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (9/6) for guard fejkse
Sep 05 16:44:43.110 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (10/6) for guard fejkse
Sep 05 16:44:44.013 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (11/6) for guard fejkse
Sep 05 16:44:44.270 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (12/6) for guard fejkse
Sep 05 16:44:44.290 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (13/6) for guard fejkse
Sep 05 16:44:51.992 [Warning] circuit_send_next_onion_skin(): Bug: Unexpectedly high circuit_successes (14/6) for guard fejkse
Sep 05 16:45:35.115 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:45:36.975 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:45:38.094 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:45:45.695 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:47:31.903 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:47:32.422 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:47:39.621 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:47:47.190 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:50:54.978 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:50:56.320 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:50:56.975 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:51:00.560 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:51:52.977 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:51:55.009 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:51:56.974 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:01.398 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:17.660 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:18.410 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:19.023 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:24.320 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:31.559 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:35.975 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:37.233 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:52:38.690 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:54:48.687 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:54:49.065 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:54:51.001 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 16:54:52.299 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:00:36.663 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:00:37.262 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:00:37.737 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:00:39.493 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:02:43.945 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:02:45.013 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:02:47.979 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.
Sep 05 17:02:51.360 [Notice] Have tried resolving or connecting to address '[scrubbed]' at 3 different places. Giving up.

Child Tickets

Attachments (1)

torrc (280 bytes) - added by hifferymchumphrey 7 years ago.
torrc

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by hifferymchumphrey

Component: - Select a componentVidalia
Owner: set to chiiph
Version: Vidalia: 0.2.20

comment:2 Changed 7 years ago by arma

Component: VidaliaTor Client
Owner: chiiph deleted
Status: newassigned
Version: Vidalia: 0.2.20

comment:3 Changed 7 years ago by arma

Looks like a duplicate of #6475?

I notice it was closed for 0.2.3 but the bug still remains in 0.2.4.

comment:4 Changed 7 years ago by nickm

Milestone: Tor: 0.2.4.x-final

It's pretty critical to know what version of Tor this is happening with. Is it a duplicate of #6475 (which we fixed), or is it happening with a version of tor where we think we fixed that?

comment:5 Changed 7 years ago by hifferymchumphrey

Version: Tor: 0.2.3.22-rc

comment:6 Changed 7 years ago by nickm

Do you have anything in your torrc that might restrict which exits are usable?

Changed 7 years ago by hifferymchumphrey

Attachment: torrc added

torrc

comment:7 Changed 7 years ago by hifferymchumphrey

ControlPort 9051
CookieAuthentication 0
DirReqStatistics 0
SocksPort 9050
StrictNodes 1
WarnPlaintextPorts 23,109
/etc/tor/torrc (END)

comment:8 Changed 7 years ago by nickm

Keywords: tor-client added

comment:9 Changed 7 years ago by nickm

Component: Tor ClientTor

comment:10 Changed 6 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: unspecified

I'm pretty sure that this might be a nothing-to-do item.

The middle set of warnings are, I think, aftermath of a case of #6475 that got persisted into the state file. (Given lack of other similar reports.) #6475 is fixed, so *that* shouldn't be coming back.

The first and final set are exactly what I'd expect if in fact you tried to connect to a port no router supported at high frequency. I wonder what mail agent the user was using here, configured to connect to the mail server how.

(I also wonder about StrictNodes 1 with no actual node constraints set.)

Does anybody have any insight on the retry issues?

comment:11 Changed 2 years ago by nickm

Resolution: worksforme
Severity: Normal
Status: assignedclosed
Note: See TracTickets for help on using tickets.