Opened 7 years ago

Closed 7 years ago

Last modified 4 months ago

#6785 closed defect (duplicate)

Bootstrap stuck at 85% when in hibernation

Reported by: tmpname0901 Owned by:
Priority: Medium Milestone: Tor: 0.2.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.3.21-rc
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was hibernating when I restarted Tor (to upgrade from 0.2.3.20 to 0.2.3.21). It seems that the bootstrap process is stuck at 85% due to the hibernation state:

Sep 06 03:27:26.000 [notice] Catching signal TERM, exiting cleanly.
Sep 06 03:27:49.000 [notice] Tor 0.2.3.21-rc (git-139a81c96d4af2f5) opening log file.
Sep 06 03:27:49.000 [notice] This version of OpenSSL has a known-good EVP counter-mode implementation. Using it.
Sep 06 03:27:49.000 [notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Sep 06 03:27:49.000 [notice] Your Tor server's identity key fingerprint is 'Unnamed 24EB8A109D4C2555B2D61BB6C70041B5C4702066'
Sep 06 03:27:49.000 [notice] Configured hibernation. This interval begins at 2012-07-31 00:00:00 and ends at 2012-09-15 00:00:00. We have no prior estimate for bandwidth, so we will start out awake and hibernate when we exhaust our quota.
Sep 06 03:27:49.000 [notice] Parsing GEOIP file /usr/share/tor/geoip.
Sep 06 03:27:49.000 [notice] Configured to measure statistics. Look for the *-stats files that will first be written to the data directory in 24 hours from now.
Sep 06 03:27:49.000 [notice] Reloaded microdescriptor cache. Found 11574 descriptors.
Sep 06 03:27:52.000 [notice] We now have enough directory information to build circuits.
Sep 06 03:27:52.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Sep 06 03:27:53.000 [notice] Bandwidth soft limit reached; commencing hibernation. No new connections will be accepted
Sep 06 03:27:53.000 [notice] Going dormant. Blowing away remaining connections.
Sep 06 03:27:53.000 [notice] Heartbeat: It seems like we are not in the cached consensus.
Sep 06 03:27:53.000 [notice] Heartbeat: Tor's uptime is 0:00 hours, with 0 circuits open. I've sent 0 kB and received 0 kB.
Sep 06 03:59:24.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Sep 06 09:27:53.000 [notice] Heartbeat: It seems like we are not in the cached consensus.
Sep 06 09:27:53.000 [notice] Heartbeat: Tor's uptime is 5:49 hours, with 60 circuits open. I've sent 1.80 MB and received 4.34 MB.
Sep 06 09:28:23.000 [notice] Our directory information is no longer up-to-date enough to build circuits: We have only 2146/3107 usable descriptors.
Sep 06 09:28:23.000 [notice] I learned some more directory information, but not enough to build a circuit: We have only 2146/3107 usable descriptors.
Sep 06 09:28:25.000 [notice] I learned some more directory information, but not enough to build a circuit: We have only 2242/3107 usable descriptors.
Sep 06 09:28:25.000 [notice] We now have enough directory information to build circuits.
Sep 06 11:32:37.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 10; recommendation warn)
Sep 06 11:32:37.000 [warn] 9 connections have failed:
Sep 06 11:32:37.000 [warn] 8 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 11:32:37.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 11:33:38.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 11; recommendation warn)
Sep 06 11:33:38.000 [warn] 10 connections have failed:
Sep 06 11:33:38.000 [warn] 9 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 11:33:38.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 11:35:40.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 12; recommendation warn)
Sep 06 11:35:40.000 [warn] 11 connections have failed:
Sep 06 11:35:40.000 [warn] 10 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 11:35:40.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 11:37:42.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 13; recommendation warn)
Sep 06 11:37:42.000 [warn] 12 connections have failed:
Sep 06 11:37:42.000 [warn] 11 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 11:37:42.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 11:41:46.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 14; recommendation warn)
Sep 06 11:41:46.000 [warn] 13 connections have failed:
Sep 06 11:41:46.000 [warn] 12 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 11:41:46.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 13:07:45.000 [warn] Your system clock just jumped 140 seconds forward; assuming established circuits no longer work.
Sep 06 13:40:42.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 15; recommendation warn)
Sep 06 13:40:42.000 [warn] 14 connections have failed:
Sep 06 13:40:42.000 [warn] 13 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 13:40:42.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 14:00:01.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 16; recommendation warn)
Sep 06 14:00:01.000 [warn] 15 connections have failed:
Sep 06 14:00:01.000 [warn] 14 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 14:00:01.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 14:29:09.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection refused; CONNECTREFUSED; count 17; recommendation warn)
Sep 06 14:29:09.000 [warn] 16 connections have failed:
Sep 06 14:29:09.000 [warn] 15 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 14:29:09.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 14:30:31.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 18; recommendation warn)
Sep 06 14:30:31.000 [warn] 17 connections have failed:
Sep 06 14:30:31.000 [warn] 16 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 14:30:31.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 14:32:12.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection refused; CONNECTREFUSED; count 19; recommendation warn)
Sep 06 14:32:12.000 [warn] 18 connections have failed:
Sep 06 14:32:12.000 [warn] 17 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 14:32:12.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 14:36:37.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 20; recommendation warn)
Sep 06 14:36:37.000 [warn] 19 connections have failed:
Sep 06 14:36:37.000 [warn] 18 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 14:36:37.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 15:27:53.000 [notice] Heartbeat: It seems like we are not in the cached consensus.
Sep 06 15:27:53.000 [notice] Heartbeat: Tor's uptime is 11:47 hours, with 137 circuits open. I've sent 5.49 MB and received 11.55 MB.
Sep 06 15:52:52.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 21; recommendation warn)
Sep 06 15:52:52.000 [warn] 20 connections have failed:
Sep 06 15:52:52.000 [warn] 19 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 15:52:52.000 [warn] 1 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 15:56:33.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (DONE; DONE; count 22; recommendation warn)
Sep 06 15:56:33.000 [warn] 22 connections have failed:
Sep 06 15:56:33.000 [warn] 20 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 15:56:33.000 [warn] 2 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN
Sep 06 18:35:32.000 [warn] Problem bootstrapping. Stuck at 85%: Finishing handshake with first hop. (Connection timed out; TIMEOUT; count 23; recommendation warn)
Sep 06 18:35:32.000 [warn] 22 connections have failed:
Sep 06 18:35:32.000 [warn] 20 connections died in state connect()ing with SSL state (No SSL object)
Sep 06 18:35:32.000 [warn] 2 connections died in state handshaking (Tor, v3 handshake) with SSL state SSL negotiation finished successfully in OPEN

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by arma

I think this counts as not-a-bug. Tor when it's hibernating isn't intended to work.

When it finishes hibernating it should bootstrap the rest of the way (though it might take it a bit of time before it notices that it can).

comment:2 Changed 7 years ago by arma

Resolution: duplicate
Status: newclosed

I'm going to close as a duplicate of #2129, since if we ever do that ticket, it'll resolve this issue.

comment:3 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.