Opened 7 years ago

Closed 7 years ago

#6793 closed defect (duplicate)

does not save disabled rules after browser restart

Reported by: onetimeuser Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using HTTPS everywhere with default configuration and SSL observatory enabled. I am not using Tor, just Windows 64 + Firefox 15.0. On some websites the HTTPS extension does not work, so I set it to disabled for this website. After I close and restart the browser, it will be enabled again. (I have to manually disable the extension for the specific website each time I want to access it.)

An example is the following (German newspaper):
http://www.faz.net/aktuell/wirtschaft/magazinbericht-merkel-will-griechenland-in-jedem-fall-im-euro-halten-11883753.html

The article is shown without a problem. If I click on "Lesermeinungen" the discussion & commentaries should be loaded (without refreshing the entire page, just see for yourself).

If HTTPS is enabled the commentaries are not shown and the following error message is given:
"Die gesuchten Inhalte sind leider derzeit nicht verfügbar. Bitte versuchen Sie es später noch einmal." (meaning: not available, come back later).

If HTTPS is disabled the commentaries are shown normally.

The problem has been consistent during the last versions of Firefox and HTTPS everywhere. Apart from HTTPS everywhere I also have installed the following extensions and plugins:
AdBlock Plus
BugMeNot
F6
Ghostery
InstaClick
Adobe Acrobat
Google Earth
Flash
Silverlight

By the way: I cannot login to this tracker as described here (Bug Tracker). The username / PW combination is not accepted:
https://www.eff.org/https-everywhere/development

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by pde

Resolution: duplicate
Status: newclosed

This is a dupe of #6653 and should be fixed in 2.2.2.

Note: See TracTickets for help on using tickets.