Opened 7 years ago

Closed 5 years ago

#6822 closed defect (fixed)

TBB x86_64 2.3.22-alpha-1 uses hardcoded control port

Reported by: phobos Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by phobos)

The latest tor-browser-gnu-linux-x86_64-2.3.22-alpha-1-dev-en-US.tar.gz has a hardcoded 9051 control port. This conflicts with system tor if you have one. Previous versions used dynamic control and socks port assignments on start.

For example, tor-browser-gnu-linux-x86_64-2.3.20-alpha-1-dev-en-US.tar.gz works correctly.

Child Tickets

Attachments (1)

vidalia-debug-log (1.8 KB) - added by phobos 7 years ago.
debug log trying to start tbb.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by phobos

Attachment: vidalia-debug-log added

debug log trying to start tbb.

comment:1 Changed 7 years ago by phobos

Description: modified (diff)

tor-browser-gnu-linux-x86_64-2.3.20-alpha-1-dev-en-US.tar.gz

comment:2 Changed 7 years ago by rransom

‘Working As Designed’ for this release, because Firefox 15 sucks more than usual.

comment:3 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:4 Changed 5 years ago by erinn

Resolution: fixed
Status: newclosed

Closing, since this is old and no longer an issue.

Note: See TracTickets for help on using tickets.