Opened 7 years ago

Closed 13 months ago

#6851 closed project (fixed)

Resume allowing website translations

Reported by: arma Owned by:
Priority: Medium Milestone: WebsiteV3
Component: Webpages/Website Version:
Severity: Normal Keywords: wants-volunteer, www-team, sebastian-0115-triaged, defer-new-website
Cc: weasel, ilv@…, frenchy, sajolida@…, phoul Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Once upon a time, we let smart people check out the website svn, edit wml text files on their own, and provide translated versions of each page.

Then we decided to get smarter about it, and switch to various web-based approaches (like running our own pootle, or using other services like transifex). Our translators disappeared. Eventually Andrew deleted all the translations.

I talked to a lot of people the past few days (at the Berlin human rights conference) who were really sad that our website is English-only. We have tsum and try to maintain its translation, which is fine. But we have lots of other content that would be more useful in other languages.

What are the minimal steps to getting our website translations back up?

Child Tickets

Change History (21)

comment:1 Changed 7 years ago by runa

I am not willing to maintain website translations as long as the website is wml. How about we pick the content that we feel is useful and important and somehow work that into the short user manual (or something similar)?

comment:2 in reply to:  1 ; Changed 7 years ago by rransom

Replying to runa:

I am not willing to maintain website translations as long as the website is wml. How about we pick the content that we feel is useful and important and somehow work that into the short user manual (or something similar)?

The point of this is to let the translators maintain the translated web pages themselves, rather than routing translations through a horrible web interface and then through you as with Transifex.

comment:3 in reply to:  2 Changed 7 years ago by runa

Replying to rransom:

Replying to runa:

I am not willing to maintain website translations as long as the website is wml. How about we pick the content that we feel is useful and important and somehow work that into the short user manual (or something similar)?

The point of this is to let the translators maintain the translated web pages themselves, rather than routing translations through a horrible web interface and then through you as with Transifex.

Someone will still have to make sure that the website builds, that the pages look ok, and so on.

comment:4 Changed 7 years ago by phobos

I've been waiting for this topic to resurface. Here's the history of website translations:

  1. We originally required all translators to keep their translations up to date using WML and SVN. Only the German and Ukrainian translations were anywhere near current. We have about 10 other languages which were old, out of date, and in some cases very poorly translated. SVN and WML were stumbling blocks to most translators.
  2. Based on a contract with BBG, we enabled pootle to make translations web-based. We gained a simplified chinese translation that was kept fairly current until the police harassed him and he stopped. We paid for some people to do translations, but more and more of our website translations were out of date. Pootle struggled with the WML and HTML inside our pages.
  3. We changed the WML publishing script to remove translations for pages with less than 80% current. This removed a lot of pages and confused a lot of users. The users would browse one page in their native language and then get forced into an English page for no apparent reason.
  4. As we lost more and more active translators, we switched to transifex because they have a large community of people already. Transifex also struggled with the non-content in our pages (WML and HTML).
  5. We changed the design of the website and no one was excited about keeping translations up to date via SVN, Pootle/Transifex or anything. As our translated pages were very out of date and about to be ridiculously out of date, we purged them and just published the English pages. TSUM was born out of a need for simple documentation and translations.

The fundamental problem with translations is that our content and code are mixed into one file. If we can separate out our content from our code on the website, we can discuss enabling website translations again. At this point, it would be easier and simpler to use bing or google web page translator than to actually hand-craft translations.

comment:5 Changed 5 years ago by arma

Keywords: wants-volunteer added

comment:6 Changed 5 years ago by phobos

Milestone: Tor Website 3.0

comment:7 Changed 5 years ago by phobos

Keywords: www-team added

comment:8 Changed 5 years ago by phobos

Owner: phobos deleted
Status: newassigned

comment:9 Changed 4 years ago by Sebastian

I'm not seeing us move away from wml anytime soon for the main site, but with the work to build the stuff on the server we could allow translators to push into a translation branch that gets auto-built, and if it works that language is copied over to the website. That way we could have maintainers for each translation. This of course requires that someone is actually willing to work with git and wml, but maybe we can convince a few people? I'm hopeful

comment:10 Changed 4 years ago by Sebastian

Keywords: sebastian-0115-triaged added

comment:11 in reply to:  9 Changed 4 years ago by arma

Replying to Sebastian:

I'm not seeing us move away from wml anytime soon for the main site, but with the work to build the stuff on the server we could allow translators to push into a translation branch that gets auto-built, and if it works that language is copied over to the website. That way we could have maintainers for each translation. This of course requires that someone is actually willing to work with git and wml, but maybe we can convince a few people? I'm hopeful

qbi earlier volunteered to work on the German version.

comment:12 Changed 4 years ago by ilv

Cc: ilv@… added

comment:13 Changed 4 years ago by boklm

A volunteer emailed the french help desk to says he's willing to help translate the website in French. I pointed him to this ticket.

comment:14 in reply to:  13 Changed 4 years ago by frenchy

Cc: frenchy added

Yes, thank you boklm for pointing me to the right ticket.

Hi guys !

As Tor is one good way to surf the web anonymously, I think it would be worthy translating the Tor Project website in order to spread the word more easily for people not speaking English, and as a french guy speaking pretty good English (I think) I could help you translate the pages in french.

Last edited 4 years ago by frenchy (previous) (diff)

comment:15 Changed 4 years ago by wilbns

Should this ticket still be open? It appears that there is an active translation project underway on Transifex and I also see commits.

comment:16 Changed 3 years ago by cypherpunks

Severity: Normal

No movement here. It's quite sad that in 2016 the Tor Project website is only available in English. Doesn't OTF have resources available for internationalizing their projects? What needs to happen to get some movement here? Is there a plan to ditch WML and move to yet-another-static-web-framework or use some kind of CRM?

comment:17 Changed 3 years ago by Sebastian

Keywords: defer-new-website added

comment:18 Changed 3 years ago by sajolida

Cc: sajolida@… added

comment:19 Changed 21 months ago by hiro

Keywords: wants-volunteer www-team sebastian-0115-triaged defer-new-websitewants-volunteer, www-team, sebastian-0115-triaged, defer-new-website

comment:20 Changed 17 months ago by arma

Cc: phoul added
Status: assignednew

Adding Colin so he knows this is a ticket (and so he can read over it for past history lessons).

comment:21 Changed 13 months ago by hiro

Resolution: fixed
Status: newclosed

I think this ticket can now be closed as we have resumed translations for the download page and the new portals will have this enabled by design.

Note: See TracTickets for help on using tickets.