Opened 7 years ago

Closed 7 years ago

#6860 closed defect (fixed)

HTTPS Everywhere for Chrome is preventing myspace from loading correctly

Reported by: jph6ttor Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: jph@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

HTTPS Everywhere for Chrome is preventing myspace.com from loading correctly.

The page is NOT rendering as intended. Instead of loading with multiple columns as it's suppose to have, content is all listed as a single column down the left-side of the page. If I disable HTTPS Everywhere for Chrome the page loads correctly.

Note that this issue seems to be unique to the Chrome version of the extension. HTTPS Everywhere for Firefox does NOT interfere with the way myspace.com displays.

Child Tickets

TicketStatusOwnerSummaryComponent
#6882closedpdeHTTPS Everywhere for Chrome is preventing site from loading correctlyHTTPS Everywhere/EFF-HTTPS Everywhere

Change History (3)

comment:1 Changed 7 years ago by jph6ttor

Component: HTTPS Everywhere: ChromeEFF-HTTPS Everywhere

comment:2 Changed 7 years ago by jph6ttor

Cc: jph@… added

comment:3 Changed 7 years ago by pde

Resolution: fixed
Status: newclosed

This CSS loading bug in MySpace seems to be fixed in HTTPS Everywhere for Chrome 2012.9.21.

There are also some parts of the MySpace site (such as videos) that break because of the mixed content issue discussed in #6975. Users can unbreak these by clicking on the shield in the address bar and doing "load insecure scripts", not that any MySpace users will ever know this. If these problems turn out to be widespread and severe, we will need to disable the MySpace rule on Chrome by default.

Note: See TracTickets for help on using tickets.