Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6905 closed defect (not a bug)

arm 1.4.5.0 connecting to tor 0.2.4.2: ProtocolError: Badly formatted reply line: unknown type 'P'

Reported by: cypherpunkx Owned by: atagar
Priority: Medium Milestone:
Component: Archived/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/TorCtl/TorCtl.py", line 635, in _loop
    isEvent, reply = self._read_reply()
  File "/usr/lib/python2.7/site-packages/TorCtl/TorCtl.py", line 810, in _read_reply
    raise ProtocolError("Badly formatted reply line: unknown type %r"%tp)
ProtocolError: Badly formatted reply line: unknown type 'P'
Terminated

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by atagar

Status: newneeds_information

Hi cypherpunkx. Thanks for the stacktrace! That's definitely a bug, but isn't enough for me to really work with. From this I can tell from that TorCtl tried to parse content that wasn't formatted like a controller message. Some possible causes are...

  • You connected to something other than tor.
  • Bug with a new tor version.
  • Some use case I'm not thinking of triggering an old bug.

... unfortunately all those causes are pretty unlikely. Are you able to consistently reproduce this? If so then to troubleshoot this we'll need to know the whole message that we're getting. To do this we'll need to tweak arm slightly (unfortunately what we need isn't exposed by TorCtl's normal logging).

If you can repro this and want to troubleshoot it further then let me know.

comment:2 in reply to:  1 Changed 7 years ago by cypherpunkx

Resolution: not a bug
Status: needs_informationclosed

Replying to atagar:

Some possible causes are...

  • You connected to something other than tor.

I inspected the traffic via wireshark and it was indeed not connecting to a tor controlport, sorry for the noise.

comment:3 Changed 7 years ago by atagar

No worries. I still think that this is a bug, however it's a problem that lies entirely within TorCtl (it should provide a method for me to catch these issues, or at least give better error output). However, TorCtl is going away (at least as far as arm's concerned) so probably not worth digging into further.

Again, thanks for the bug report!

Note: See TracTickets for help on using tickets.