Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6942 closed defect (not a bug)

Closing all TorBrowser tabs closes also Vidalia

Reported by: matti Owned by: chiiph
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.2.39
Severity: Keywords: TorBrowser Vidalia close tabs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Closing all TorBrowser tabs closes also Vidalia. This is especially inconvenient if I am running a relay node because I don't know if Tor is running anymore.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by matti

This happened on Windows Vista Business.

comment:2 Changed 7 years ago by matti

I installed TorBrowser bundle.

comment:3 in reply to:  description ; Changed 7 years ago by rransom

Component: VidaliaTor bundles/installation
Resolution: not a bug
Status: newclosed

Replying to matti:

Closing all TorBrowser tabs closes also Vidalia.

This is intended, partly because there is no way to restart TBB-Firefox after it has exited.

This is especially inconvenient if I am running a relay node because I don't know if Tor is running anymore.

With all recent versions of Tor Browser Bundle, the Tor process ends whenever Vidalia exits.

If you want to run a relay on Windows, please use the relay-by-default bundle. That bundle should be compatible with running Tor Browser Bundle at the same time; if it isn't, please open a bug report about that.

comment:4 in reply to:  3 Changed 7 years ago by rransom

Replying to rransom:

If you want to run a relay on Windows, please use the relay-by-default bundle. That bundle should be compatible with running Tor Browser Bundle at the same time; if it isn't, please open a bug report about that.

(If TBB doesn't work with a relay-by-default bundle running at the same time, the workaround is to follow the steps listed at https://www.torproject.org/docs/faq#TBBSocksPort in reverse in your TBB. But please file a bug report anyway.)

Note: See TracTickets for help on using tickets.