Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6976 closed task (not a bug)

Two tor clients

Reported by: Intellektus Owned by:
Priority: Very High Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have been experimenting with the thought of running two Tor clients at once on my machine. So I decided to try it and modified the source a bit to let me run two clients at once (of course with separate data dirs). But they both get the same exit node, and if I try to switch exit node on one of them via its control port, they both get switched.

I have been experimenting with this some more, and Tor always seem to get the same IP, even if I run several separate clients (on the same machine) at once.

Is this the expected behavior?

Child Tickets

Change History (8)

comment:1 Changed 7 years ago by nickm

Milestone: Tor: unspecified

Um. You shouldn't need to modify the source to run two separate Tor clients. Just make sure they have different SocksPorts and controlports and different DataDirs.

comment:2 in reply to:  1 Changed 7 years ago by Intellektus

Replying to nickm:

Um. You shouldn't need to modify the source to run two separate Tor clients. Just make sure they have different SocksPorts and controlports and different DataDirs.

Where can I set them? Explain.

Thanks

comment:3 Changed 7 years ago by nickm

In a torrc file. You can tell Tor to start with a non-default torrc file by starting it with "-f filename" on the command line, where you replace "filename" with the path to the actual file you want to open.

comment:4 Changed 7 years ago by Intellektus

Can you write down here the solution? I think the complete file content. Example: 2 different TOR Clients

Thanks

comment:5 in reply to:  3 Changed 7 years ago by Intellektus

Replying to nickm:

In a torrc file. You can tell Tor to start with a non-default torrc file by starting it with "-f filename" on the command line, where you replace "filename" with the path to the actual file you want to open.

Can you write down here the solution? I think the complete file content. Example: 2 different TOR Clients
Thanks

comment:6 Changed 7 years ago by karsten

Component: - Select a componentTor

comment:7 Changed 7 years ago by arma

Resolution: not a bug
Status: newclosed

Closing, since this user needs to get tech support from somewhere else than our bug tracker.

comment:8 Changed 7 years ago by arma

(hint: you might like the #tor channel on irc.)

Note: See TracTickets for help on using tickets.