Opened 7 years ago

Closed 7 years ago

#6999 closed defect (not a bug)

Old script to block non-tor traffic doesn't work with new bundle.

Reported by: cypherpunks Owned by: runa
Priority: Medium Milestone:
Component: User Experience/Tor Support Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There is a script here - https://trac.torproject.org/projects/tor/wiki/doc/BlockNonTorTrafficDebian - that is supposed to "block all local outbound traffic except for Tor in Debian [& Ubuntu]" but it doesn't work with the browser bundle. Running that script just blocks EVERYTHING including tor as far as I can tell.

The page was revised just a few days ago so I would have thought it was current. It has one more line in it than an earlier version did. The earlier version also shuts down everything including the bundle. Is there a script for this that will work with the bundle? If not, is it possible to actually install the tor-browser, and maybe it would work in that case?

Also, are there similar commands for OpenBSD?

I know this sounds more like a forum post than a wiki entry or a bug report, but I couldn't find a better place to put it.

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by karsten

Component: - Select a componentTor Support
Owner: set to runa

comment:2 Changed 7 years ago by runa

Resolution: not a bug
Status: newclosed

I suggest you check out Tails instead: https://tails.boum.org/

Note: See TracTickets for help on using tickets.