Opened 11 years ago

Last modified 7 years ago

#700 closed defect (Fixed)

Installation error - maybe connected to OSX 10.5.3?

Reported by: chewey Owned by: phobos
Priority: Low Milestone:
Component: Core Tor/Tor Version: 0.1.2.19
Severity: Keywords:
Cc: chewey Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Im getting an installation error of a postflight script not running for both

vidalia-bundle-0.1.2.19-0.0.16a-tiger.dmg
vidalia-bundle-0.2.0.27-rc-0.1.3-tiger.dmg

I have searched through the various help pages, and the one and only time I can find this error referred to is in the Vidalia
forum. The problem with the answer I found here is that is that it refers to an installer log and I cant find that on my machine...

I have recently upgraded to OSX 10.5.3 as well and assume this might well be an issue as its very recent.

[Automatically added by flyspray2trac: Operating System: OSX 10.5 Leopard]

Child Tickets

Change History (11)

comment:1 Changed 11 years ago by phobos

Can you look through /var/log/install.log, near the end. This file should have a log of what failed during the
installation.

comment:2 Changed 11 years ago by chewey

The problem was that I had not copied the installer to the drive I was installing on. I have now installed without error.
As a general rule I normally run installers from mounted drives without problems so speaking as a non programmer this information would be helpful in the install notes.

Many thanks for the prompt reply.

comment:3 Changed 11 years ago by phobos

Well, you're supposed to mount the dmg and double click the installer. This is how it's supposed to work.
You shouldn't have to copy anything.

comment:4 Changed 11 years ago by chewey

Well TOR is definately working as I have used the test tool from the TOR site in Firefox and it tells me thats its working fine.

However I understand that does not help you with the situation that it should be working from the mounted disk image. I will try the unstable version of the software. Is the /var/log/install.log supposed to be found on the mounted drive during the install? or in a library somewhere?

Many thanks

comment:5 Changed 11 years ago by phobos

Ok, so what you're saying is that the installation worked, the installer just thinks it failed.

comment:6 Changed 11 years ago by chewey

Sorry, my mail has been offline.

Pretty much. Im not sure it matters that much as anyone intelligent enough to be looking for browsing by proxy is going to be savvy enough to work this out.

comment:7 Changed 11 years ago by chandra1000

I'm getting the same error, with version 0.2.0.31-0.1.9. The install fails at the postflight script, Vidalia will run and connect to the network, but Privoxy is not configured and Torbutton is not visible in Firefox. Where is the script file located so I can check it? Here's the errors from install.log:

Sep 10 21:50:52 ChandraPB Installer[1688]: run postflight script for Tor
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: moz_libdir=/usr/local/lib/firefox-
3.0.1: Command not found.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: found=0: Command not found.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: progname=/Applications/Firefox.app/Contents/MacOS/firefox: Command not found.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]:
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: progname: Undefined variable.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]:
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: curdir=: Command not found.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]:
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: progname: Undefined variable.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]:
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: progbase=: Command not found.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]: curdir: Undefined variable.
Sep 10 21:50:53 ChandraPB runner[1691]: postflight[1740]:
Sep 10 21:50:53 ChandraPB Installer[1688]: Install failed: The following install step failed: run postflight script for Tor. Contact the software manufacturer for assistance.
Sep 10 21:50:53 ChandraPB Installer[1688]: IFDInstallController 75B890 state = 7
Sep 10 21:50:53 ChandraPB Installer[1688]: Displaying 'Install Failed' UI.
Sep 10 21:50:53 ChandraPB Installer[1688]: 'Install Failed' UI displayed message:'The following install step failed: run postflight script for Tor. Contact the software manufacturer for assistance.'.

comment:8 Changed 11 years ago by phobos

I can't recreate this at all. Is your default shell perhaps different than what ships with OS X? the default shell is bash.

comment:9 Changed 10 years ago by phobos

Is this still a problem?

comment:10 Changed 10 years ago by phobos

flyspray2trac: bug closed.

comment:11 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.