Opened 5 years ago

Closed 5 years ago

#7068 closed defect (not a bug)

continue enigmail support, just fail closed

Reported by: proper Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: proper, sukhbir.in@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

"We dropped Enigmail support for now to be able to drop the HTTP proxy requirement." This is really sad.

Alternative solution, perhaps as a stopgap:

  • Let Enigmail traffic fail closed.
  • Continue to support Engimail, just state that networking features do not work, known limitation.
  • Post correct instructions in TorifyHOWTO/GnuPG article.
  • Suggest to use gpg command line (correctly torified) to use keyservers.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by sukhbir

Cc: sukhbir.in@… added

Enigmail is supported in 0.0.13 (source code), it's just that the traffic is fail-closed for now. I will update the documentation to better reflect what it meant. We have no plans to drop Enigmail support, we are most probably going to ship TorBirdy with shim so that HTTP traffic is routed through SOCKS and there are no leaks.

comment:2 Changed 5 years ago by sukhbir

Resolution: not a bug
Status: newclosed

I am going to close this ticket. Feel free top reopen it in case you have any more questions.

Note: See TracTickets for help on using tickets.