Opened 7 years ago

Closed 7 years ago

#7078 closed defect (fixed)

Torbutton 1.4.6.2/3 causes Firefox 16 to crash

Reported by: victorj Owned by: mikeperry
Priority: Very High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-rebase, MikePerry201212
Cc: david.ludovino@… Actual Points: 1
Parent ID: #7248 Points:
Reviewer: Sponsor:

Description

I updated firefox to 16. On restart it just crashed. Ran from terminal, still crashed. In safe-mode it ran properly. After disabling/enabling various addons & plugins, found that if Torbutton is disabled Firefox 16 runs without crash.

Just a thought: it might be due to the small pop window message, torbutton shows everytime at startup.

Firefox 16
Torbutton 1.4.6.2

Child Tickets

Change History (16)

comment:1 Changed 7 years ago by dll

Cc: david.ludovino@… added
Keywords: 16 startup added

Same problem here. It's certainly due to Torbutton.

comment:2 Changed 7 years ago by arma

If you can get this crash to happen in a Tor Browser Bundle, I bet Mike will pay more attention to it.

As it is now, it's likely in the "please submit a patch" state since Torbutton-outside-TBB is unmaintained.

comment:3 Changed 7 years ago by gk

The bug range is: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80499f04e875&tochange=1e56d3016820

and the issue (as it is shown through gdb) is:

++DOCSHELL 0x8d00400 == 1 [id = 1]
++DOMWINDOW == 1 (0x8d2ab9c) [serial = 1] [outer = (nil)]
++DOMWINDOW == 2 (0x8d2394c) [serial = 2] [outer = 0x8d2ab50]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805E0006: file ../../../../xpfe/appshell/src/nsWebShellWindow.cpp, line 233
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805E0006: file ../../../../xpfe/appshell/src/nsAppShellService.cpp, line 353
WARNING: requested removal of nonexistent window: file ../../../../../embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 1224
--DOCSHELL 0x8d00400 == 0 [id = 1]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805E0006: file ../../../../xpfe/appshell/src/nsAppShellService.cpp, line 106
WARNING: NS_ENSURE_SUCCESS(rv, 0x80004005) failed with result 0x805E0006: file ../../../toolkit/xre/nsAppRunner.cpp, line 3758
[Thread 0xae136b70 (LWP 30196) exited]
--DOMWINDOW == 1 (0x8d2394c) [serial = 2] [outer = 0x8d2ab50] [url = about:blank]
--DOMWINDOW == 0 (0x8d2ab9c) [serial = 1] [outer = (nil)] [url = about:blank]
[New Thread 0xae136b70 (LWP 30197)]
[New Thread 0xa83ffb70 (LWP 30198)]
[New Thread 0xa77ffb70 (LWP 30199)]

  • Call to xpconnect wrapped JSObject produced this error: *

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource:///modules/webappsUI.jsm :: webappsUI_uninit :: line 25" data: no]

WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 166
[Thread 0xb23b8b70 (LWP 30189) exited]
WARNING: GetWindowsTable returned null: file ../../../dom/base/nsWindowMemoryReporter.cpp, line 627
[Thread 0xa77ffb70 (LWP 30199) exited]
[Thread 0xb2bb9b70 (LWP 30188) exited]
[Thread 0xae9efb70 (LWP 30195) exited]
[Thread 0xa83ffb70 (LWP 30198) exited]
[Thread 0xae136b70 (LWP 30197) exited]
[Thread 0xaf5c5b70 (LWP 30194) exited]
[Thread 0xb05c7b70 (LWP 30192) exited]
[Thread 0xafdc6b70 (LWP 30193) exited]
[Thread 0xb11c8b70 (LWP 30191) exited]
[Thread 0xb3bf6b70 (LWP 30187) exited]
[Thread 0xb1b90b70 (LWP 30190) exited]
WARNING: OOPDeinit() without successful OOPInit(): file ../../../toolkit/crashreporter/nsExceptionHandler.cpp, line 2226
WARNING: OOPDeinit() without successful OOPInit(): file ../../../toolkit/crashreporter/nsExceptionHandler.cpp, line 2226
nsStringStats

=> mAllocCount: 8711
=> mReallocCount: 491
=> mFreeCount: 8691 -- LEAKED 20 !!!
=> mShareCount: 12443
=> mAdoptCount: 636
=> mAdoptFreeCount: 636

[Inferior 1 (process 30172) exited with code 01]

Seems not to be a crash but rather a "normal" shutdown.

comment:4 Changed 7 years ago by anonymous6748

I can confirm this. While running Tor outside of the Tor Browser Bundle might not be supported, that's not really ideal for users who use a Tor middle box, that they connect to via ssh tunnel or vpn.

Perhaps there should be a version of the Tor Browser that doesn't include Tor. Also the lack of the TBB package in the debian repositories is rather annoying for users wanting to automatically keep their software updated.

comment:5 Changed 7 years ago by gk

After a lot of bisecting, we got a winner: https://hg.mozilla.org/mozilla-central/rev/1d17123006b3

"Just a thought: it might be due to the small pop window message, torbutton shows everytime at startup." - No, that is not the case. Thus, I would be surprised if that is not affecting the TBB as well. Mike?

comment:6 in reply to:  5 Changed 7 years ago by victorj

Replying to gk:

After a lot of bisecting, we got a winner: https://hg.mozilla.org/mozilla-central/rev/1d17123006b3

"Just a thought: it might be due to the small pop window message, torbutton shows everytime at startup." - No, that is not the case. Thus, I would be surprised if that is not affecting the TBB as well. Mike?

So, does it mean problem is with FF16 & not with TorButton? I could not understand the code at your link, but it seems to be relating to resolved bug https://bugzilla.mozilla.org/show_bug.cgi?id=789773

comment:7 Changed 7 years ago by mikeperry

Keywords: MikePerry201210 tbb-rebase added; firefox 16 torbutton crash startup removed

comment:8 Changed 7 years ago by victorj

Summary: Torbutton 1.4.6.2 causes Firefox 16 to crashTorbutton 1.4.6.2/3 causes Firefox 16 to crash

what does tbb-rebase mean? since, crash,torbutton, etc were removed. I thought it was fixed. So, i checked site for patch. There is 1.4.6.3 released 10Oct2012. Updated Torbutton, restarted browser. Then, updated FF to 16.0.1, restarted browser. It started as usual. But, i could not visit any site. Then, closed it and started afresh, now it wont start again. crashed/silent-autoshutdown.

comment:9 Changed 7 years ago by mikeperry

Component: TorbuttonTorBrowserButton
Owner: set to mikeperry

tbb-rebase means this was an issue with a Firefox Rapid Release code change that we have to deal with due to Firefox changes that broke our code. It is used for accounting purposes.

Wrt keywords: Non-dev users shouldn't be using keywords. I think I've adjusted trac permissions to prevent this confusion from happening in the future. If not: For future reference, the removal of junk keywords does not mean that the concept that the removed junk keyword thought it referred to was fixed/changed. It merely means the nonsense was removed from the keyword field.

Please try to keep further meta-discussion about trac state changes out of the bug tracker. There are better places to discuss and ask about how we use trac (like IRC and mailinglists).

comment:10 Changed 7 years ago by gk

The issue is at least affecting Torbutton versions down to 1.3.1-alpha (iff Torbutton is activated). I haven't had time to convince older versions to work with FF16 in order to test them.

comment:11 Changed 7 years ago by hexhub

For the time being, AdvTor might be of help until torbutton is fixed.

http://sourceforge.net/projects/advtor/

comment:12 in reply to:  4 Changed 7 years ago by proper

Replying to anonymous6748:

Perhaps there should be a version of the Tor Browser that doesn't include Tor.

It exists. Just needs a one line change in the startup bash script. You can use the Tor Browser (Bundle) without Tor/Vidalia. I documented it:

https://trac.torproject.org/projects/tor/wiki/doc/TorifyHOWTO/WebBrowsers

comment:13 Changed 7 years ago by rransom

katmagic removed everything that mentioned “IWebProgressListener” from Torbutton and tested it (in Firefox 16.0.1), and the crash still occurred.

The last Torbutton log message that Firefox prints before exiting is:

Torbutton NOTE: Skipping no location: chrome://adblockplus/locale/subscriptionSelection.dtd

comment:14 Changed 7 years ago by cypherpunks

After updating firefox from v15.0.1 to v16.0.1 the browser starts but I cannot reach any URL typed in the address bar or any bookmarked one.

The error console shows messages like this one for each URL I've tried to reach

[10-18 14:23:04] Torbutton NOTE: Blocking nullprinciple request from:  [scrubbed]

Closing firefox and restarting it doesn't work apparently because firefox silently shuts down .

comment:15 Changed 7 years ago by mikeperry

Keywords: MikePerry201210 removed
Parent ID: #7248

Didn't get to this this month. Probably will need to figure it out for FF17-ESR, though.

comment:16 Changed 7 years ago by mikeperry

Actual Points: 1
Keywords: MikePerry201212 added
Resolution: fixed
Status: newclosed

Turns out this is due to Firefox nsIContentPolicy changes. I've branched Torbutton for 1.5 and removed the content policy that attempts to prevent cross-tor-state loads after toggle in origin/master.

This means that toggle is now totally unsafe for reals. I'll probably be renaming the extension to something like "Tor Support" once we get closer to a FF17-ESR TBB release.

Note: See TracTickets for help on using tickets.